jrgces

jrgces

 268K puntos  Madrid, España @jrgces desde - visto

Preguntas esperando respuesta

Actividad pública reciente

Ha respondido en

Hay alguna Fórmula para contar caracteres?

=LARGO(A1)-LARGO(SUSTITUIR(A1;"e";""))
Ha respondido en

Contar numero de repeticiones sucesivas en una serie

Para simplificar un poco la fórmula vamos a suponer que el rango A1:H1 es un rango con nombre llamado "serie". La fórmula entonces creo que podría ser: =SUMA(SIGNO(FRECUENCIA(SI(serie=1;COLUMNA(serie));SI(serie=0;COLUMNA(serie))))) teniendo en cuenta...
Ha respondido en

Necesito fórmula para sumar el tiempo entre dos fechas.

Intenta: =E9+(1*(E9<D9))-D9 Saludos_
Ha respondido en y en 3 temas más

Crear dos tablas en una hoja con datos en celdas de otra hoja.

Yo probaría con una tabla dinámica (Datos->Insertar->Tabla dinámica). Saludos_
Ha respondido en y en 1 temas más

Se puede usa K.esimo.Mayor filtrado por dos fechas?

Intenta: =K.ESIMO.MAYOR(SI(($A$2:$A$100>=$F$1)*($A$2:$A$100<=$F$2)=1;$B$2:$B$100);FILA()-3) en E4. Extender hasta E6. Para los valores menores sería lo mismo pero en otra columna y sustituyendo .MAYOR por . MENOR La fórmula es matricial. Saludos_
Ha respondido en y en 2 temas más

¿Cómo seleccionar una rango a partir de una celda variable por VBA?

Prueba con algo como: Sub prueba() Dim r As Range Set r = Range("Datos!I15").Resize(Range("Datos!B34").End(xlUp).Row - 14, 12) r.Copy [Portada!J13].PasteSpecial Paste:=xlPasteValues, Operation:=xlNone, SkipBlanks _ :=False, Transpose:=True...
Ha respondido en

¿Qué fórmula puedo usar en Excel para contar valores únicos en un rango de celdas que están separadas?

Sospecho que tiene que haber una forma más fácil de hacerlo, pero ahora mismo no se me ocurre. En D2: =SUMA(1*ESNUMERO(HALLAR(FILA(INDIRECTO("1:4"));SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(B1&C1&F1&H1;B1;1);C1;2);F1;3);H1;4)))) Extender hacia abajo...
Ha respondido en

Actualizar asistencia al turno

Yo creo que el primer argumento de ese BUSCAR tendría que ser sólo E9, extendiendo luego la fórmula hacia abajo. También habría que hacer absolutas las referencias a la hoja STATUS porque si no se hace así dichas referencias irían cambiando al...
Ha respondido en

Calcular orden de merito evaluando dos criterios

La forma más rápida de conseguirlo parece ser mediante el uso de una columna auxiliar, pongamos que la C. En C3, extendiéndo la fórmula hasta C10: =B4+(MAX(A4;$A$4:$A$10)-A4) En D3, extendiéndo la fórmula hasta D10: =JERARQUIA.EQV(C4;$C$4:$C$10)...
Ha respondido en

Valor 1 según coincidencia de 2 celdas

Intenta: =SI.ERROR(SIGNO(COINCIDIR($H3&I$1;$B$2:$B$5&$C$2:$C$5;0));"") en I2. Extender hacia abajo y hacia la derecha.
Ha respondido en y en 2 temas más

¿Cómo configurar un patrón de velas japonesas?

No estoy seguro de entender del todo qué es lo que necesitas, así que pongo un enlace a un libro de ejemplo para ver si al menos se aproxima a lo que buscas: http://www.jrgc.es/ejemplos/ejemplo_20200204a.xlsx En Velas! A:A están las velas expresadas...
Ha respondido en y en 2 temas más

Fórmula en excel para obtener la hora en que inicia y termina el exceso de tráfico dependiendo de valores obtenidos

Tal como están los datos no se me ocurre la forma de conseguir lo que necesitas, pero si no estuviese la fila 2 (que además parece estar duplicada con la última fila), las fórmulas podrían ser: =INDICE(B2:B25;MIN(SI(ESNUMERO(C2:C25);FILA(2:25)-1)))...
Ha respondido en y en 2 temas más

Solo mostrar resultados con coincidencia absoluta VBA Formulario

En principio parece que los "culpables" son el like de la instrucción If LCase(hojabase2.Cells(i2, j2).Offset(0, 0).value) Like "*" & LCase(Me.num_equipament_final.Caption) & "*" Then y los dos asteriscos. Prueba con algo como If...
Ha respondido en y en 2 temas más

Gráfico de velas actualizable según celdas

Yo contesté hace tiempo a una pregunta parecida. Si quieres mira si te sirve de algo la respuesta, al menos para empezar: https://www.todoexpertos.com/preguntas/6i5mpii6dmxagawo/como-hacer-un-grafico-con-rango-variable?selectedanswerid=6i85g3xhpxedjxpe
Ha añadido un comentario en una respuesta de la pregunta

Buscar una fecha entre unos rangos de fechas y extraer un valor asociado de la fila donde se ha hallado esa fecha

respondió: Era justo lo que necesitaba. Se ve tan simple ahora, y tantas horas de quebraderos de cabeza que me ha traído. Le he añadido un SI. ERROR para que no aparezca #/NA cuando no encuentra un valor.

Experiencia

Programador en VBA para Excel desde hace años, pero cada vez me gusta más hacer las cosas con las funciones de hoja de cálculo de Excel, y cuanto más complicadas resulten las fórmulas, mejor :]