jrgces

jrgces

 241K puntos  Madrid, España @jrgces desde - visto

Preguntas esperando respuesta

Actividad pública reciente

Ha respondido en

Encontrar coordenadas de un valor en una tabla

Suponiendo que la tabla tiene asignado un rango con nombre Datos y el valor a encontrar el nombre Valor_a_encontrar, prueba con la siguiente fórmula:...
Ha respondido en y en 2 temas más

Cómo puedo saber el número de horas que pasan entre dos horas en excel?

Suponiendo que la fecha y hora inicial están en A1 y la fecha y hora final están en B1, intenta: =(DIAS.LAB(A1+1;B1-1)*(10/24))+((ENTERO(A1)+"17:00")-A1)+(B1-(ENTERO(B1)+"07:00")) teniendo en cuenta que: - Quizás haya que sustituir el punto y coma...
Ha respondido en y en 2 temas más

Error Metodo Select de clase Range

¿La hoja activa cuando se intenta seleccionar celdas de BFDG1 es BFDG1? Es lo más obvio que se me ocurre. Saludos_
Ha respondido en y en 1 temas más

Error en compilación excel vba

Parece que falta marcar la referencia a la librería "Microsoft Word XX.x Object Library", donde XX. X dependerá de la versión de Word instalada en el equipo, aunque en principio, dependiendo de la versión de Office, no debería ser necesario. Esto se...
Ha respondido en y en 2 temas más

Crear formato condicional celdas Excel

Teniendo seleccionado el rango E2:E12, prueba a poner esta fórmula para el formato condicional de ese rango: =E2<>INDICE($B$2:$B$12;COINCIDIR(DESREF(E2;;-1);$A$2:$A$12;0)) Saludos_
Ha respondido en y en 1 temas más

Calculo de intereses proporcional a la fecha evaluada

Prueba poniendo en C1: =(B1*5*(HOY()-FECHA(AÑO(A1);MES(A1);1)+1))/36500 copiar y pegar en C2.
Ha respondido en

Excel - Buscar con dos criterios en rango numérico

Prueba poniendo en la celda debajo de "Resultado esperado:" =INDICE($D$3:$D$9;SI.ERROR(COINCIDIR(G3;SI((F3>=$A$3:$A$9)*(F3<=$B$3:$B$9)>0;$C$3:$C$9);0);COINCIDIR(0;SI((F3>=$A$3:$A$9)*(F3<=$B$3:$B$9)>0;$C$3:$C$9);0)))
Ha respondido en

Sustituir valores de unas celdas con los datos contenidos en dos columnas

No está claro lo que necesitas. Si, como parece, se trata de poner en la columna G (no en la H) el código alfanumérico de la columna I que corresponda con la misma fila de la columna F, intenta: =INDICE(I:I;COINCIDIR(F1;H:H;0)) a partir de I1 hacia...
Ha respondido en

Desafío excel búsqueda matriz devolver valor anterior con varios valores

Prueba poniendo en la fila 2 de cualquier columna vacía: =INDICE(C:C;K.ESIMO.MAYOR(SI($B$2:B2=B2;$A$2:A2);2)+1) extendiendo después la fórmula hacia abajo hasta donde haya datos. A tener en cuenta que: - Se trata de una fórmula matricial, por lo que...
Ha respondido en y en 2 temas más

Extraer 10 filas que tengan una celda con un valor mayor del total de filas.

Se puede hacer con fórmulas. En cualquier celda de la fila 1 de una columna vacía: =INDICE(A:A;COINCIDIR(K.ESIMO.MAYOR(D:D;FILA());D:D;0)) Copiar y pegar hasta la fila 3. Si pudiese haber "empates" en la columna D habría que complicar la fórmula.
Ha respondido en

Excel. Tablas dinámicas. Actualización automática.

Una de las causas de ese error es que la tabla dinámica no se llame como pone en el código. Puedes averiguar el nombre de la tabla dinámica 1 de la hoja activa con: msgbox.activesheet.pivottables(1).name De todas formas, dado que normalmente sólo hay...
Ha respondido en

Coincidencia de dos columnas y agregando la info de una tercera columna.

Suponiendo que las claves en Hoja1 empiezan en A2, intenta: =INDICE(Hoja2!B:B;COINCIDIR(Hoja1!A2;Hoja2!A:A;0))
Ha respondido en y en 2 temas más

Lista de valores únicos distintos de cero

Para simplificar un poco la fórmula vamos a suponer que al rango A1:A5 se le ha aplicado el nombre Datos. En la fila 1 de cualquier columna vacía: =INDICE(Datos;K.ESIMO.MENOR(SI((COINCIDIR(Datos;Datos;0)=FILA(Datos))*(Datos<>0);FILA(Datos));FILA()))...
Ha respondido en

Abrir formulario desde un rango de celdas

Suponiendo que el formulario se llama UserForm1, prueba con: Private Sub Worksheet_BeforeDoubleClick(ByVal Target As Range, Cancel As Boolean) If Target.Column = 4 Then Cancel = True UserForm1.Show End If End Sub en el módulo de la hoja (pulsación...
Ha respondido en

Ordenar columnas en base al valor del valor de varias celdas en excel

No sé si he entendido el problema, pero si las filas ya están ordenadas por PTO, DF y GA parece que no hace falta recurrir a JERARQUIA y podría bastar con usar la función FILA. Si, como parece, el 1 debajo de "POS." está en la fila 3, prueba con...
Ha respondido en y en 2 temas más

Cómo hacer un Gantt en excel?

Quitando las "S" que van delante de los números de semana creo que se puede hacer más o menos lo que necesitas, usando fórmulas matriciales (hay que introducirlas pulsando mayúsculas control entrada al mismo tiempo) en el rango K4:AJ15. El problema...

Experiencia

Programador en VBA para Excel desde hace años, pero cada vez me gusta más hacer las cosas con las funciones de hoja de cálculo de Excel, y cuanto más complicadas resulten las fórmulas, mejor :]