jrgces

jrgces

 292K puntos  Madrid, España @jrgces desde - visto

Preguntas esperando respuesta

Actividad pública reciente

Ha respondido en

Dudas con la Función si no puedo sacar la fórmula correcta

No sé si lo he entendido bien, pero intenta: ="Galardón "&COINCIDIR(E6;{0;250;330;350;450;500;650;670;730;800;880;900;1000;1200;1500;1700;2000;2500;2900;3700;4100;4500;5000};1) Saludos_
Ha respondido en y en 1 temas más

Macro para comprobar si el N.I.F. Es correcto

No es necesario recurrir a VBA. Yo preparé hace tiempo un libro de ejemplo con fórmulas para validar tanto NIFs como NIEs: http://www.jrgc.es/ejemplos_funcvarias/averiguar_letra_DNI.xls Saludos_
Ha respondido en y en 1 temas más

Fórmula que sume las cantidades a la derecha del signo de pesos

Si tiene Excel 365 (y quizás también 2019, no estoy seguro), pruebe con: =SUMA(SI.ERROR(XMLFILTRO("<t><s>"&SUSTITUIR(SUSTITUIR(SUSTITUIR(IZQUIERDA(A1;LARGO(A1)-1);"$";"");" ";",");",";"</s><s>")&"</s></t>";"//s");0))
Ha respondido en

Como encontrar un numero dependiendo de otro y ultima fecha

Por ejemplo, si los datos están en A2:C20 y el código a buscar es "a": =INDICE(SI(B2:B20="a";C2:C20);COINCIDIR(MAX(SI(B2:B20="a";A2:A20));SI(B2:B20="a";A2:A20);0)) teniendo en cuenta que:
Ha respondido en y en 2 temas más

¿Como quitar duplicados de una columna en un Array Bidireccional VBA (Excel)?

Por probar: Sub prueba() Dim m(1 To 10, 1 To 10) As Variant, mm As Variant Dim n As Integer, s As String m(1, 1) = 1: m(2, 1) = "a" m(1, 2) = 1: m(2, 2) = "b" m(1, 3) = 1: m(2, 3) = "c" m(1, 4) = 2: m(2, 4) = "d" m(1, 5) = 2: m(2, 5) = "e" m(1, 6) =...
Ha respondido en y en 1 temas más

¿Cuantas columnas tiene mi Array birideccional?

Intenta: ubound(matriz,2)-lbound(matriz,1)+1 Saludos_
Ha respondido en y en 1 temas más

¿Realizar filtro de una tabla y pegado en Listbox?

Si tienes el Excel 365 (quizás el 2019 también, pero no estoy seguro), cargar en Listbox1 los valores únicos de la columna Columna3 de Tabla1 en el orden en el que estén es tan fácil como Private Sub UserForm_Initialize() Me.ListBox1.List =...
Ha respondido en y en 1 temas más

VBA como evaluar el valor de una variable a partir de un texto

No creo que la sintaxis de VBA admita referenciar una variable mediante el valor de otra variable. Hasta donde yo sé, esto no es posible (aunque está claro que podría estar equivocado). Si he entendido el problema, una posible solución sería que VAR1...
Ha respondido en y en 2 temas más

Macro VBA copiar y pegar eliminando celdas vacías

Prueba con: Sub prueba() Dim rngR As Range With Worksheets("Hoja2") Set rngR = .Range("A3:A" & CStr(.[A100000].End(xlUp).Row)).SpecialCells(xlCellTypeConstants) rngR.Copy .[C3].PasteSpecial xlValues End With Set rngR = Nothing End Sub Saludos_
Ha respondido en

Calcular promedio de días de vida

En G2: =PROMEDIO.SI.CONJUNTO($F$2:$F$17;$E$2:$E$17;E2) Estender hacia abajo hasta donde haga falta. Saludos_
Ha respondido en

No me funciona comparación de dos celdas iguales

Si conviertes ambos valores a número antes de hacer la comparación no debería haber problemas: =SI(1*B1=1*C1;"OK";"") Saludos_
Ha respondido en y en 2 temas más

Copiar rango de celdas a otro excel VBA

Prueba con algo parecido a: Sub prueba() Dim filaDondeCopiar As Integer: filaDondeCopiar = 13 Dim f As Integer Dim LibroDestino As Workbook, LibroOrigen As Workbook, HojaDestino As Worksheet, HojaOrigen As Worksheet Set LibroDestino =...
Ha respondido en y en 1 temas más

¿Crear procedimiento para vaciar los items de un listbox de cualquier formulario?

En principio no parece necesario vaciar un listbox quitando uno a uno sus elementos. Si el listbox fue rellenado con AddItem, prueba con NombreListbox. Clear Y si fue rellenado con RowSource: NombreListbox.RowSource="" Saludos_
Ha respondido en y en 2 temas más

Error al quiere poner una fórmula en una celda desde vba

Intente: temporal.Range("B2:B" & uFila).FormulaLocal = "=SI(LARGO(A2)-LARGO(SUSTITUIR(A2;""\"";""""))>1;EXTRAE(A2;ENCONTRAR(""\"";A2;2)+1;9);ESPACIOS(EXTRAE(SUSTITUIR(A2;"" "";REPETIR("" "";99));2;99)))" aunque resulta difícil saber si funcionará, al...
Ha respondido en y en 1 temas más

Obtener Ultima Celda con valores

Pruebe con: Public Function ÚltimaCeldaLibroCerrado(sLibro As String, sHoja As String) As Variant 'Nota1: dependiendo de la versión de Excel, puede ser necesario establecer una referencia a la _ librería Microsoft ActiveX Data Objects que tenga la...
Ha respondido en

Mensaje emergente, si dos celdas cumplen con una palabra aparezca mensaje de aviso

Prueba con una validación de datos (solapa 'Datos') para la celda G7. En Configuración, Fórmula: =(E7="TERCERO")*O(G7="GIRO";G7="COBRO";G7="EMISION")=0 y en Mensaje de error "NO CORRESPONDE"

Experiencia

Programador en VBA para Excel desde hace años, pero cada vez me gusta más hacer las cosas con las funciones de hoja de cálculo de Excel, y cuanto más complicadas resulten las fórmulas, mejor :]