jrgces

jrgces

 281K puntos  Madrid, España @jrgces desde - visto

Preguntas esperando respuesta

Actividad pública reciente

Ha respondido en

Buscar palabra clave dentro de un texto en una celda de Excel e insertar el estatus en otra celda.

Pruebe con: =INDICE({"Current";"Superseded";"Canceled";"Duplicated"};COINCIDIR(1;SIGNO(HALLAR({"Current";"Superseded";"Canceled";"Duplicated"};B2)))) teniendo en cuenta que: - Si la versión de Excel no es la 365, la fórmula deberá ser introducida...
Ha respondido en y en 1 temas más

Contar si participa en eventos consecutivos

Llevo varios días intentando responder pero sale un error. No sé si será por la fórmula, así que he subido a un ejemplo a http://www.jrgc.es/ejemplos/ejemplo_20210224.xlsx pero sólo funciona en Excel 365 y Excel 2019.
Ha respondido en

Excel crear secuencial según dos criterios

Esta fórmula (en C2, extender hasta C8) devuelve los mismos resultados que los que hay en la columna C de la imagen:...
Ha respondido en

Encontrar fecha anterior a un rango

Si las fechas están siempre ordenadas de menor a mayor, puedes probar con: =MAX(DESREF(A1;;;COINCIDIR(C3;A:A;0)-1))
Ha empezado a seguir la pregunta

Recuento y asociación de datos categóricos Excel situados en distintas columnas

Estoy realizando la interpretación de datos de una encuesta y necesito ayuda para hacer un recuento y asociarlas a respuestas categóricas comunes situadas en columnas distintas. Lo he estado intentando hacer usando tablas dinámicas y no consigo que...
Ha respondido en y en 1 temas más

Como filtrar datos de presiones y temperaturas cada minuto si los tengo cada 5 segundos

Suponiendo que los datos de un día de una de las muestras están en A1:A86400, la siguiente fórmula en, por ejemplo, B1:B1440 devolverá el promedio de dicha muestra cada minuto: =PROMEDIO(DESREF($A$1;(FILA()-1)*12;;12)) Quzás haya que sustituir los...
Ha respondido en y en 1 temas más

Error al ejecutar la macro para copiar columnas de una hoja a otra

Sub prueba() Dim rngOrigen As Range, rngDestino As Range, rngTemp As Range Dim i As Integer Set rngOrigen = Worksheets("PO").Range("W:W,T:T,AG:AG,F:F,C:C,U:U,B:B,Y:Y,Z:AA,AB:AH") Set rngDestino = Worksheets("New_POTemp").[A:A] For Each rngTemp In...
Ha respondido en y en 1 temas más

¿Cómo calcular el dígito de verificación del nit para Colombia?

Parece que se puede conseguir usando una fórmula. Suponiendo que el NIT (9 dígitos, sin el dígito de control final) está en A1:...
Ha respondido en y en 1 temas más

Como desmarcar todas las checkbox en excel

Prueba con algo como: Sub prueba() Dim n As Integer For n = 1 To Worksheets("Hoja1").CheckBoxes.Count Worksheets("Hoja1").CheckBoxes(n) = False Next n End Sub Saludos_
Ha respondido en y en 1 temas más

Sumar si excel discriminando fecha

Prueba con esta fórmula, en la que tendrás que cambiar D2 por la dirección de la celda que esté debajo de "Total", extendiéndola luego hacia abajo:...
Ha respondido en y en 1 temas más

Error en evento Ontime con condicional

El LatestTime:=0 no hace falta para detener el OnTime, pero no creo que sea ese el problema. Creo que tendrás que verificar qué tipo de variable es Tiempo, y qué contiene cuando se ejecuta el Application. Ontime Esta es la documentación de Microsoft...
Ha respondido en

Fórmula o función EXCEL para contar según unos requisitos

Suponiendo que HOY esté en A1: =CONTAR.SI.CONJUNTO(B3:K3;"<"&B1;B4:K4;"si") Saludos_
Ha respondido en

Fórmula en Excel para arrastrar

=C3*$A$1 debería funcionar. Saludos_
Ha respondido en y en 4 temas más

¿Cómo se pone un Countdown a las 10:00 am, 2:00 pm, 8 :00 pm?

El VBA de Excel dispone del método OnTime, que ejecuta un procedimiento a la hora que se le diga. Habría que pegar este código en el módulo del libro (en Thisworkbook): Private Sub Workbook_Open() Dim dtSiguiente As Date Select Case Time Case Is <...
Ha respondido en y en 2 temas más

Copiar celdas excel con VBA

Quizás te sirva este ejemplo que preparé hace tiempo: http://www.jrgc.es/ejemplos/ejemplo_20101123a.xls No es exactamente lo mismo, porque aquélla consulta era para conseguir un listado de los tiempos cronometrados manualmente, pero creo que el...
Ha respondido en y en 1 temas más

Macro para imprimir con impresora que no sea la predeterminada

Sin ver el código VBA es difícil precisar, pero en principio parece que debería ser suficiente con averiguar cuál es la hoja activa en el momento de la impresión. Esto es fácil de conseguir mediante activesheet.name Saludos_

Experiencia

Programador en VBA para Excel desde hace años, pero cada vez me gusta más hacer las cosas con las funciones de hoja de cálculo de Excel, y cuanto más complicadas resulten las fórmulas, mejor :]