jrgces

jrgces

 256K puntos  Madrid, España @jrgces desde - visto

Preguntas esperando respuesta

Actividad pública reciente

Ha respondido en y en 2 temas más

Duda sobre datos externos me da error Valor

La causa más frecuente de ese error en una multiplicación es que uno de sus factores sea un texto. Para empezar, yo revisaría qué es exactamente lo que hay en E2. Saludos_
Ha respondido en y en 2 temas más

Como utilizar buscarv para encontrar valor coincidente

La columna donde están los códigos ¿tiene formato de texto? BUSCARV ¿tiene encerrado entre comillas el código a buscar? Si ambas respuestas son afirmativas, BUSCARV debería funcionar, así que convendría algún ejemplo. Saludos_
Ha respondido en

¿Es posible encontrar el Valor Anterior y Fecha Anterior en Secuencia?

La fórmula para la fecha anterior no resulta demasiado complicada: =SI.ERROR(K.ESIMO.MAYOR(SI($C$2:$C$6=C2;SI($A$2:$A$6<A2;$A$2:$A$6));1);"") La que devuelve el valor correspondiente a esa fecha anterior sí se complica un poco más, y no veo la forma...
Ha respondido en

Obtener el valor de una celda a partir de otro valor dado en otra celda (2)

Por ejemplo, si el rango es A1:E100 intenta: =INDICE(E1:E100;COINCIDIR(MIN(ABS(C1:C100-0,65));ABS(C1:C100-0,65);0)) Se trata de una fórmula matricial, por lo que hay que introducirla pulsando mayúsculas control entrada al mismo tiempo. Si en C1:C100...
Ha respondido en

Como encontrar el mínimo mayor que 0 con condición

Suponiendo que el rango sea A1:B5, intenta: =MIN(SI(A1:A5="Juan";SI(B1:B5>0;B1:B5))) teniendo en cuenta que: - Se trata de una fórmula matricial, por lo que ha de ser introducida pulsando mayúsculas control entrada al mismo tiempo
Ha respondido en

Obtener el valor de una celda a partir de otro valor dado en otra celda

Intenta: =INDICE(E:E;COINCIDIR(MAX(C:C);C:C;0)) Saludos_
Ha respondido en

Determinar Números En Medio o Distancia de 2 Números. Calcular Pares/Impares Individualmente

Si el número inicial está en B2 y el final en C2, estas fórmulas parece que devuelven los resultados esperados: =REDONDEAR.MENOS((C2-B2-1)/2;0)+1*ES.PAR(B2+1) para los pares y: =REDONDEAR.MENOS((C2-B2-1)/2;0)+1*ES.IMPAR(B2+1) para los impares; pero...
Ha respondido en

Macro Excel para generar Combinaciones

Yo tengo hecho un libro para listar combinaciones sin repetición, si quieres mira si te sirve: http://www.jrgc.es/ejemplos/generar_combinaciones.xls Saludos_
Ha respondido en y en 2 temas más

Suma de los últimos POR números de una serie

Con fórmula, intenta: =SUMA(DESREF(B2;;CONTAR(B2:K2)-3;;3)) suponiendo que el rango sea A1:L2 Saludos_
Ha respondido en

¿Como calcular con excel horas nocturnas?

Esta fórmula parece que hace lo que necesitas, pero tendrás que probar si funciona en todos los casos: =(1+MIN(L8;$AD$4))-MAX(I8;$AC$4)-(K8+SI(K8<J8;1)-J8) Saludos_
Ha respondido en

Buscador de datos por fecha en rangos de fechas.

Prueba con estas fórmulas, a ver si hacen lo que necesitas. En Control! C4: =COUNTIFS(Planned!$Q:$Q,">="&Control!C$3,Planned!$Q:$Q,"<="&Control!C$3+7) en Control!C5: =COUNTIFS(Planned!$R:$R,">="&Control!C$3,Planned!$R:$R,"<="&Control!C$3+7) en...
Ha respondido en

Como generar en Excel las 128 combinaciones que se generan cuando se juega con 7 dobles en una quiniela de 14 juegos?

Esto creo que hace más o menos lo que necesitas: www.jrgc.es/ejemplos/ejemplo_20190816a.xlsx En la columna A van los 14 resultados fijos (1=local, 2=empate, 3=visitante). En la columna B van los 7 dobles. En la columna C están los 128 binarios que...
Ha respondido en

¿Qué función debo utilizar para que me busque el puntaje del primero y el segundo y el tercer puesto en excel?

Suponiendo que la tabla con los puestos está en F3:J6 y los datos en B2:C20, prueba con =K.ESIMO.MAYOR(SI($B$2:$B$20=G$3;$C$2:$C$20);$F4) en G4. Extender hasta J6.
Ha respondido en y en 2 temas más

Buscar Valor y Repeticiones y calcular días entre ocurrencias

Cambiando el orden de los datos (primero la fecha más antigua y al final la más reciente), esta fórmula parece que hace lo que necesitas: =A10-INDICE(A:A;K.ESIMO.MENOR(SI($B$2:$B10=B10;FILA($A$2:$A10));MAX(CONTAR.SI($B$2:B10;B10)-1;1))) Hay que...
Ha respondido en y en 3 temas más

Combobox donde no se puedan introducir más datos de los que muestra.

Yo probaría a "jugar" con las propiedades EnterFieldBehavior y/o MatchEntry del combobox ( F4 teniendo seleccionado el control en el modo diseño del userform ) Saludos_

Experiencia

Programador en VBA para Excel desde hace años, pero cada vez me gusta más hacer las cosas con las funciones de hoja de cálculo de Excel, y cuanto más complicadas resulten las fórmulas, mejor :]