jrgces

jrgces

 237K puntos  Madrid, España @jrgces desde - visto

Preguntas esperando respuesta

Actividad pública reciente

Ha respondido en y en 2 temas más

Lista de valores únicos distintos de cero

Para simplificar un poco la fórmula vamos a suponer que al rango A1:A5 se le ha aplicado el nombre Datos. En la fila 1 de cualquier columna vacía: =INDICE(Datos;K.ESIMO.MENOR(SI((COINCIDIR(Datos;Datos;0)=FILA(Datos))*(Datos<>0);FILA(Datos));FILA()))...
Ha respondido en

Abrir formulario desde un rango de celdas

Suponiendo que el formulario se llama UserForm1, prueba con: Private Sub Worksheet_BeforeDoubleClick(ByVal Target As Range, Cancel As Boolean) If Target.Column = 4 Then Cancel = True UserForm1.Show End If End Sub en el módulo de la hoja (pulsación...
Ha respondido en

Ordenar columnas en base al valor del valor de varias celdas en excel

No sé si he entendido el problema, pero si las filas ya están ordenadas por PTO, DF y GA parece que no hace falta recurrir a JERARQUIA y podría bastar con usar la función FILA. Si, como parece, el 1 debajo de "POS." está en la fila 3, prueba con...
Ha respondido en y en 2 temas más

Cómo hacer un Gantt en excel?

Quitando las "S" que van delante de los números de semana creo que se puede hacer más o menos lo que necesitas, usando fórmulas matriciales (hay que introducirlas pulsando mayúsculas control entrada al mismo tiempo) en el rango K4:AJ15. El problema...
Ha respondido en

Copiar de una hoja de excel y pegar en otra hoja los datos transpuestos

Si he entendido el problema, creo que una tabla dinámica (solapa Insertar) hace exactamente lo que necesitas. Un saludo_
Ha respondido en y en 1 temas más

Calculo de tiempo transcurrido entre fechas horas

Pienso que lo más lógico sería usar la función DateDiff de VBA. Saludos_
Ha respondido en

Contar Rachas de un conjunto de datos en Excel

Suponiendo que la serie de unos y ceros está en A1:A9, prueba con: =SUMA(SIGNO(FRECUENCIA(SI(A1:A9=0;FILA(A1:A9));SI(A1:A9=1;FILA(A1:A9)))))+SUMA(SIGNO(FRECUENCIA(SI(A1:A9=1;FILA(A1:A9));SI(A1:A9=0;FILA(A1:A9))))) teniendo en cuenta que:
Ha respondido en y en 2 temas más

Macro para transformar la primera letra de cada palabra, en mayúscula dentro de la hoja.

Prueba con: Private Sub Worksheet_Change(ByVal Target As Range) If Target.Cells.Count > 1 Then Exit Sub Target.Value = WorksheetFunction.Proper(Target.Value) End Sub Saludos_
Ha respondido en

Cómo encontrar valores comunes a varias celdas de excel?

No sé si lo he entendido, y además la fórmula que creo que hace lo que creo haber entendido que hace falta que haga es enorme, y además me temo que tardará bastante si tiene que procesar más de 300.000 celdas. En cualquier caso, allá va:...
Ha respondido en y en 2 temas más

Macro para que me elimie algún texto con condición de un rango

En principio parece que no hace falta recurrir a VBA. Intenta: =SUSTITUIR(SUSTITUIR(ESPACIOS(SUSTITUIR(SUSTITUIR(N1;" ";"█");"\";" "));" ";"\");"█";" ")
Ha respondido en

Fórmula para encontrar fechas de día 15 y ultimo de cada mes

Por ejemplo, en A1 15/09/18. En A2: =SI(DIA(A1)=15;FIN.MES(A1;0);A1+15) Copiar y pegar hacia abajo hasta donde sea necesario.
Ha respondido en y en 1 temas más

Filtrar Combobox (lista) para quitar nombres repetidos.

Una posibilidad, suponiendo que el rango con los nombres duplicados tiene aplicado el nombre "Lista": Private Sub UserForm_Initialize() On Error GoTo captura Dim n As Long For n = 1 To Range("Lista").Rows.Count Me.ComboBox1.AddItem...
Ha respondido en

Asignar categoría de acuerdo a textos

En, por ejemplo, Hoja2! J1: =INDICE(Hoja1!B:B;COINCIDIR(VERDADERO;ESNUMERO(HALLAR(Hoja1!$A$1:$A$174;I1));0)) teniendo en cuenta que: - Se trata de una fórmula matricial, por lo que hay que introducirla pulsando mayúsculas control entrada al mismo...
Ha respondido en

Una fórmula de excel para sumar

No sé si lo he entendido. Suponiendo que el número está en A1, prueba con: =SI(RESIDUO(A1;9)=0;9;RESIDUO(A1;9)) Quizás tengas que sustituir los puntos y comas por el separador de listas que esté establecido en la configuración regional del equipo. Un...
Ha respondido en y en 1 temas más

Subtotal con Filtros de texto

Prueba con: =SUMA(SUBTOTALES(3;DESREF(C2:C242;FILA(2:242)-MIN(FILA(2:242));;1))) Se trata de una fórmula matricial, por lo que hay que introducirla pulsando mayúsculas control entrada al mismo tiempo. La función MIN podría no ser necesaria si se sabe...
Ha respondido en

Cómo crear formato condicionado celda por celda.

"Jugando" con la función DESREF parece que se podría hacer lo que necesitas sin demasiados problemas. He subido un ejemplo a http://www.jrgc.es/ejemplos/ejemplo_20180822a.xlsx Lógicamente, la sintaxis concreta de las fórmulas para los formatos...

Experiencia

Programador en VBA para Excel desde hace años, pero cada vez me gusta más hacer las cosas con las funciones de hoja de cálculo de Excel, y cuanto más complicadas resulten las fórmulas, mejor :]