Daniel Espino

Daniel Espino

Cuando sientas que no puedes seguir, da 3 pasos más...
 60,8K puntos  Ciudad de México, México @danielespino2 desde - visto
Preguntar

Actividad pública reciente

Ha respondido en y en 2 temas más

¿Cómo evitar que se trabe excel?

Cuando pones muchas fórmulas cada que haces un cambio por mínimo que parezca vuelve a calcular todas tus fórmulas lo que gasta recursos en tu computadora, lo mejor cuando son muchos datos es usar macro, ¿Cómo tienes tus datos?
Ha respondido en

Zoom en Celda de excel para escribir

Te propongo esta solución, no es como tal un "zoom" lo que hace es cambiarle las propiedades a la celda activa y al salir te regresa las propiedades anteriores. Pruébala en la hoja 1 Ojalá te sirva Private Sub Worksheet_SelectionChange(ByVal Target...
Ha respondido en y en 2 temas más

Ejecutar macro solo si no se rebasa la fecha del reloj del equipo

Se me ocurre un ejemplo: Sub caduca() hoy = Date limite = CDate(10 / 5 / 2021) If hoy <= limite Then MsgBox "la macro ya no es vigente" Else '<--------tu macro End If End Sub
Ha respondido en y en 2 temas más

Excel vba problema al ejecutar macro desde checkbox

Bueno ya que solo pones eso no se el evento que estas poniendo para aplicar la macro. Solo necesitas quitar los paréntesis a Now, te dejo un ejemplo: Private Sub CheckBox1_Click() If CheckBox1.Value = True Then Range("C2").Value = Now End Sub Se...
Ha respondido en y en 1 temas más

Como ejecutar una macro al cambiar el valor de la celda b4

Puedes agregar el evento change en la hoja que quieres Private Sub Worksheet_Change(ByVal Target As Range) If Target.Address = "$A$1" Then Nombrar_Hojas End Sub
Ha respondido en y en 1 temas más

Verificar que nuevas filas estén incluidas en un rango con formula (sumar)

No estoy seguro de haberte entendido. ¿Quieres qué sin importar cuantas filas nuevas ingreses las considere la suma? Si es el caso con algo así creo que es suficiente: =SUMA(INDIRECTO("$d$2:$d"&FILA()-1)) Sumará todos los valores de tu columna d...
Ha respondido en

Asignar porcentaje de acuerdo a cierto precio

¿Supongo qué quieres algo como esto no? =SI(Y(A1>=1,A1<=499),"20%",SI(Y(A1>=500,A1<=999),"18%",SI(Y(A1>=1000,A1<=1499),"16%",SI(Y(A1>=1500,A1<=2000),"14%"))))
Ha respondido en y en 2 temas más

Macro que me automaticé un buscarv

Perdona, he estado ocupado si gustas mándame un archivo de ejemplo y como es que lo necesitas [email protected]
Ha respondido en y en 1 temas más

Separar entero, punto, y decimal como entero, a tres celdas diferenciadas

Para mi es más fácil con macro te evitas algunas operaciones en celdas y y fórmulas Sub dividir() Dim a As String Dim b() As String a = Cells(1, 1) b = Split(a, ".") Cells(1, 2).NumberFormat = "@" Cells(1, 2) = String(10 - Len(b(0)), "0") & b(0)...
Ha respondido en y en 2 temas más

Macro para copiar dato de A1 - HOJA1 en la primer celda vacía de la columna "C" - HOJA2

Con algo así debería ser suficiente: Sub copiar() Set h1 = Sheets("Hoja1") Set h3 = Sheets("Hoja3") h3.Cells(1, 3).End(xlDown).Offset(1, 0) = h1.Cells(1, 1) End Sub
Ha respondido en y en 1 temas más

¿Puede actualizarse de forma automática la fecha en un inputbox?

Te dejo un pequeño ejemplo: Sub fecha() b = InputBox("Ingrese la fecha", , Date) MsgBox b End Sub Si te fijas al ejecutarlo en el inputbox aparece la fecha del día de hoy y puedes modificarla a tu gusto.
Ha respondido en

SUMAR SI haciendo referencia a texto de otra hoja

No estoy muy seguro de haberte entendido. Pero si en la hoja uno quieres hacer tu concentrado algo así: y en la hoja 2 estan los pagos pendientes supongamos algo así: en B2 de la hoja 1 usas: =SUMAR.SI(Hoja2!$A$2:$A$14,Hoja1!A2,Hoja2!$B$2:$B$14) y...
Ha respondido en y en 2 temas más

Activar suma en la barra de estado y también que sume el rango seleccionado

Muy probablemente es que tu rango a sumar no te los detecta como números Intenta cambiarlos a números en el triangulito verde que está en la esquina superior izquierda de las celdas.
Ha respondido en

Como usar correctamente Aplication.ScreenUpdating

¿Cómo la estas usando? ¿Puedes subir un pedazo del código donde tiene la línea? Revisa que tenga esta estructura: Application.ScreenUpdating = False En caso contrario, ¿Si la estas escribiendo bien? Application.ScreenUpdating = False
Ha respondido en

Como contar filas con filtro

Tal como te dice el compañero con subtotales queda Suponiendo que tus datos a contar son el rango g3:g700 como ejemplo la fórmula sería así: =SUBTOTALES(3,G3:G700)
Ha respondido en y en 1 temas más

Como hacer una fórmula para evaluar cinco columnas en excel

Si te entendí bien con esto es suficiente: =SI(O(SUMA(A3:D3)>=1,E3="OBESIDAD"),"SI","NO") Recuerda cambiar los separadores de coma(,) por punto y coma (;) de acuerdo a tu configuración.

Experiencia

Humano común

Trabajo

  • por ahí
    Analista , actualmente

Educación

  • x
    administración