pitcher_

pitcher_

 18,4K puntos  Chile @pitcher_ desde - visto

Actividad pública reciente

Ha respondido en

Fórmula que devuelva Si o NO

La función "Si" te puede ayudar como esta : =SI(A1=B1;"Si";"No") o tambien dando una consulta al resultado : =SI(D1=VERDADERO;"SI";"NO")
Ha respondido en

Correo masivo de excel a outlook

Solo agregue en tu código un "\" cuando das la ruta del archivo y funciono. Y deje como comentario objMessage. Display por que anterior mente haces al objeto un log off y funciona. Public Sub SendMail() 'On Error GoTo Err_SendMail Dim objOutlook As...
Ha respondido en

Macro para puesto de excel

Disculpa la demora en contestar, pero no tenia tiempo. Mira pega este código: Sub Puesto() Ciclo = Range("E65535").End(xlUp).Row Range("A2:E" & Ciclo).Select Selection.Sort Key1:=Range("E1"), Order1:=xlDescending, Header:=xlGuess, _ OrderCustom:=1,...
Ha respondido en

Identificar ultima columna que contenga datos

Para identificar la ultima columna es de la siguiente manera Aux = Range("IV16").End(xlToLeft).Column
Ha respondido en y en 1 temas más

Checkbox

Para que te agregue los valores en la misma celda es así. ActiveCell.Value = "" For I = 1 To 3 If Me.Controls("Checkbox" & I).Value = True Then ActiveCell.Value = ActiveCell.Value & " " & Me.Controls("checkbox" & I).Caption & vbCrLf End If Next I
Ha respondido en

Generar Alerta de Vencimientos de Pagos a Proveedores

Se puede hacer, tengo varias ideas de como hacerlo. Este código es cuando uno abre el archivo y revisa tu fórmula de =DIAS360(HOY();A5) y si el menor a 3 envía el mensaje. Este código debes pegarlo en ThisWorkbook Private Sub Workbook_Open() If...
Ha respondido en

Pasar parámetros a una consulta

Por más que intente darle al recordset la consulta de access no me fue posible, creo que lo único que tienes que hacer es darle la sentencia de Sql. Suerte Pitcher !
Ha respondido en

Mover fórmulas de acuerdo a los datos copiados

Que te parece si me envías el archivo a [email protected] Así podre trabajar directamente en lo que necesitas y vemos que se puede hacer. Saludos Pitcher!
Ha respondido en

Macros excel

Este código es como para orientarte en lo que tu quieres. Si ya tienes el archivo guardado con los nombres. Mira este código lo tienes que pegar en la hoja el cual están los nombres. Private Sub Worksheet_Change(ByVal Target As Range) Dim Filas,...
Ha respondido en

Formulario hoja1 y guardar datos en hoja2

Intenta seleccionar el rango de la siguiente manera: Sheets("Hoja2").Range("A1").Select Se produce este error por que el commandbutton1 (botón), esta como objeto en la hoja1. Es por este motivo que se debe dejar de esta manera.
Ha respondido en

Fórmulas excel

He generado para ti dos códigos, los cuales uno es para grabar la lista de nombres y te crea un archivo txt en C:\. Y otro código para cargar los datos guardados en el archivo de texto. Mira copia estos códigos en la planilla donde están los Nombres...
Ha respondido en

Archivos con macros y contraseña de apertura

Deshabilita la seguridad de macro en el 2003 es : - Herramientas - Macro - Seguridad - Pon la opción bajo y listo. En 2007 es : - Boton de office (el boton de la esquina superior izquierda) - Opciones de Excel (esta al lado del boton Salir de excel)...
Ha respondido en

Necesito crear un código en Visual Basic donde se abra una hoja llamada boleta y no me aclaro.

Te da error por que en VBA no esta establecido el App. Path y este comando es reemplazado por ActiveWorkbook. Path, desarrolle un código para lo que necesitabas: Sub abrir() StrCarpeta =ActiveWorkbook.Path + "\" ChDir StrCarpeta StrArchivos =...
Ha respondido en

Macro, oculta filas, mediante aplicación externa Excel

Se produce el error por que con este comando Range("a15:a38"). Value, tratas de ver el valor de un rango. Te recomiendo que lo hagas por separado y no en rango. Si necesitas borrar todos los registros #N/A. Te recomiendo hacer esto : Cells.Select...