Problemas con wifi

Tengo un PC con Windows XP y hace ya más de un año que tengo contratado el dúo de Telefónica a 3 Mb. El router es el Comtrend CT-5361, y tengo un adaptador inalámbrico comprado aparte, el Conceptronic C54RU. Hace ya casi un mes perdí la conexión y desinstalé y volví a instalar tanto el router como el adaptador pero no he conseguido nada más que tener problemas. El icono de conexión establecida me aparece, figura como conectado y sin embargo, no me funciona ninguna aplicación que utilice la red. Llamé a Telefónica y me confirmaron que la red me funcionaba, diciéndome que el problema era del adaptador. Me puse en contacto con quien me vendió el adaptador y al probarlo, comprobaron que funcionaba perfectamente. El problema era que no se me instalaba bien este último, pues no me aparecía el icono y al iniciar el ordenador me aparecían estos dos mensajes de error:
1. No se encuentra el punto de entrada del procedimiento apsSearchInterface en la biblioteca de vínculos dinámicos wlanapi.dll
2. No se encuentra el punto de entrada del procedimiento apsInitialize en la biblioteca de vínculos dinámicos wlanapi.dll
Instalé el Windows Service Pack 3 para XP, ya que me dijeron que así se solucionaba. Nada de nada. Además, me recomendaron conseguir los drivers actualizados del adaptador, así que los descargué de la página de Conceptronic y en esta ocasión me salió otro mensaje diferente:
3. Error al iniciar la aplicación porque no se encontró wnicapi.dll. La reinstalación podría reparar el problema.
Ayer, cansado ya de tanto problema, conecté el equipo directamente al router a través de un cable de red, y de esta manera, funciona perfectamente. La pega, es que tengo que trasladar todo el equipo a otra habitación, y eso, para un caso de urgencia lo puedo hacer, pero permanentemente, no. A estas alturas sigo sin tener conexión inalámbrica a Internet, y mientras tanto, Telefónica sigue pasándome los recibos religiosamente.
¿Existe alguna solución?
1

1 Respuesta

160.550 pts. Tecnico Informatico
El archivo que te da error lo puedes descargar de:
http://www.archivos-dll.es/wlanapi.dll,4771
Lo bajas y lo pegas(si tienes instalado el xp en c:) en la ruta:
C:\WINDOWS\system32\
Después decirte que los adaptadores usb wifi suelen traer un programa independiente de conexión wifi y debes desactivar el que hace las mismas funciones del propio windows.
También comprueba en Administrador de dispositivos que no tengas algún icono de error en algún componente de red.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas