Jose Armando

Jose Armando

 México @josearmando2 desde - visto
Preguntar

Actividad pública reciente

Ha valorado "Excelente" la respuesta

Buscar un dato en un libro y obtener el nombre de la hoja donde se encuentre

respondió: Te anexo la macro actualizada Sub Buscar() 'Act.Por.Dante Amor Set h1 = Sheets("Poliza") num = h1.Range("C11") For Each h In Sheets Set b = h.Columns("B").Find(num, lookat:=xlWhole) If Not b Is Nothing Then MsgBox "Su póliza se encuentra en el mes "...
Ha valorado "Excelente" la respuesta

Macro para cancelar un cuadro de selección de hoja de fórmula de excel

respondió: :) Tan simple como: Sub Muestra() On Error Resume Next Range("D218") = 0 Range("D218") = "=VLOOKUP(R5C5,Hoja2!R7C4:R10C50,25,0)" End Sub Espero no haber "llegado tarde" y que te sea de utilidad. :) .
Ha valorado "Excelente" la respuesta

Macro para adjuntar un archivo a un correo de outlook ya creado

respondió: H o l a : Lo más simple es que pongas los dos archivos al momento de ejecutar la macro. Asigna la siguiente macro a tu botón que vas a poner en cada hoja: Sub EnviarCorreo() nuevo = CreateObject("Outlook.application") Dim mensaje As Outlook.MailItem...
Ha valorado "Excelente" la respuesta

Fórmula para enumerar celdas de manera consecutiva sólo si hay datos en ellas

respondió: Lo puedes hacer así: En tu caso, en E3 formulas esto: =SI(D3="NO";"";CONTAR.SI(D3;"SI")) En E4 esto: =si($D$3:D4="NO";"";contar.si($D$3:D4;"SI")) .. y lo arrastras hasta el final.
Ha valorado "Excelente" la respuesta

Se puede cambiar el ícono de una carpeta de manera definitiva?

respondió: Te puedo explicar como, pero me tienes que decir que sistema operativo tienes.
Ha valorado "Buena" la respuesta

Ejecutar macro en todas las hojas visibles de un libro deExcel

respondió: Intenta con esto: Sub Borrar_solo_visibles() For i = 1 To Sheets.Count If Sheets(i).Visible = True Then Sheets(i).Select Range("C11:Z11,AE11,AF11:AG11,AI11").Select Selection.ClearContents Range("F13:G24, J13:K24, O13:P24, T13:U24, Y13:Z24,...
Ha valorado "Excelente" la respuesta

Usar hypervínculos en celdas protegidas

respondió: No lo veo posible salvo que las celdas con hipervínculos queden desbloqueadas. Sdos. Elsa
Ha valorado "Buena" la respuesta

Condicionar una macro según el valor de un Textbox en un formulario

respondió: Intenta esto: Private Sub CommandButton1_Click() If Sheets("hoja1").Range("I54").Value = "" Or _ Sheets("hoja1").Range("I54").Value = 0 Then Cells(54, 9) = Me.TextBox1.Value Else respuesta = MsgBox("desea reemplazar los valores", vbYesNo,...