Error al reproducir midi

Tengo un problemilla, hasta hace unos días todo iba genial, pero no se que instalé o toqué, que ahora cuando intento reproducir un archivo mid me dice el winamp que "error: Se ha usado un identificador de dispositivo que está fuera del intervalo para su sistema", pero lo raro es que si me indica el tiempo de la canción. Y si lo intento con el windows media, parece que lo reproduce pero no suena.
Solo me pasa con los mid, los demás archivos de sonido van genial.
Mi tarjeta de sonido es una SoundMax, integrada en la placa base. (Creo que se dice así)
En fin, que este es mi problema.
2

2 Respuestas

675 pts. Empleo Actual: Jefe del Depto de Sistemas en la empresa...
¿Has intentado realizar una prueba con el DirectX?. Si no la has realizado, la puedes hacer de la siguiente forma.
Abre le menu inicio y selecciona la opción Ejecutar, escribe la palabra dxdiag y presiona enter. Abre la pestaña de Música y presiona el botón Probar DirectMusic utilizando cada uno de los puertos enlistados en la parte superior, si la prueba falla con alguno de estos, identificalo y me comentas cual fue el que fallo, posteriormente te diré la forma en que se pueda solucionar el problema...
Le paso el directx y todo funciona a la perfección, y me suena la música.
Otra cosa que no comenté antes, si me voy al panel de control y le doy a "dispositivos de audio y sonido", en la pestaña de audio, me sale preseleccionado para reproducción y grabación de sonido la Soundmax, pero para reproducir Midi sale en blanco. Si pincho en ella, me deja elegir "Sint. SW de tabla de ondas GS", pero una vez que le doy a aplicar y aceptar y cierro, y luego lo vuelvo a abrir, ya se ha quedado en blanco.
En fin, que no se que hacer, espero que esta información te sirva.
Pues no, pero si hago eso ¿no me borrará todo lo que le he instalado desde entonces? Y han sido muchas muchas cosas.
¿Qué windows tienes?
Si tienes XP, ¿has intentado realizar la recuperación del sistema desde el punto donde hiciste el movimiento que desactivo tu tarjeta de sonido?
El problema no es a nivel hardware, más bien es a nivel software, concretamente dentro del registro de windows. Aunque pudiera ser arreglado necesitaríamos revisar todas las entradas de registro y ver cuales son las incorrectas y cambiarlas por las correctas, el problema es que puedes tener alrededor de 10,000 entradas de registro y ya te imaginaras lo que resultaría de revisar una por una. La recuperación del sistema hace eso por ti, sin embargo, como bien lo dices, te desintalaria todo lo que haz instalado desde entonces...
Bueno, pues tendré que resignarme y esperar a que el ordenador necesite un formateo.
Muchas gracias por la atención que me has prestado.
11.600 pts.
Mmmm miraste en el panel de control, dispositivos de sonido y audio, en "audio", abajo tienes una opción para configurar la reproducción de música Midi. Probablemente hayas cambiado algo allí...
Hombre, nunca me a salido ese mensaje de error..."Se ha usado un identificador de dispositivo que está fuera del intervalo para su sistema"... probaría lo típico, reinstalar drivers, ir a un punto de restauración de sistema cuando funcionaba o reinstalar todo el sistema incluso...

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas