Swf de Flash 5.0 en Director 8.5 no Funciona Bien

Hola:
Tengo un problema y es el siguiente:
Resulta que tengo un swf hecho en flash 5.0, el cual tiene algunos botones que abren algunos ejecutables externos que me funciona perfectamente. El problema esta en que cuando lo importo a director los botones no funcionan.
Ya he intentado activando en la lista de interacciones de las propiedades del cast las opciones de buttonsenable y actionsenable pero aun así no me funciona.
Si sabes que hacer al respecto te agradecería muchísimo.
Suerte y gracias de antemano.
1

1 respuesta

Respuesta
1
Prueba a poner esto en el canal de script:
On exitframe me
if sprite(1).mouseoverbutton then
alert "el raton acaba de pasar sobre\
Un boton de la pelicula de flash que\
Esta situada en el sprite 1"
end if
end
Si esto te funciona es porque reconoce a los botones al pasar el ratón sobre ellos y no se puede hacer nada más en director.
Hola bedelludrica.
Antes que nada quiero darte las gracias por responderme tan pronto. He probado el script y me funciona, por lo tanto quiere decir que los botones son reconocidos por director, ¿pero entonces puedo concluir que tanto los botones como las acciones de flash no funcionan en director?... Porque si es así no tiene caso seguir programando menús en flash, yo se que en director se pueden hacer garndes cosas pero lamentablemente hasta ahora estoy en proceso de aprendizaje.
Si existe alguna manera de hacer funcionar mis menús de flash en director te agradecería si me la contaras.
Suerte.
Si, si funcionan pero ese comando no funciona. El resto de las cosas si funcionan, es decir todos las acciones con movimientos que programes en flash te funcionaran (menús, botones, sonido, navegación..).

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas