Director 8.5 y precarga

Tengo un proyecto con mucho video y al llegar al primer punto del score donde el video aparece el Proyector se queda bloqueado. Esto ocurre, en ordenadores distintos y menos potentes al que he usado para realizar el proyecto, al chutarse el Cd. Lo que es cierto, es que en otros proyectos que he realizado había también bastante video y no tenía problemas de reproducción. Por eso comento lo de la precarga. En este sentido me gustaría que me dijeras un código para aplicar sobre un miembro del cast al principio (las clásicas letras "loading" en loop) para que se cargue la película entera antes de saltar de ese "loadin" inicial.
También te indico un código que he usado sobre un cast que hace ejecutarse un par de videos en el instante en que se bloquea por si fuese motivo del problema:
Global sVideo
On beginSprite me
sVideo = 1
sprite(sVideo).visible = false
end
on mouseEnter me
sprite(sVideo).visible = true
sprite(sVideo).movieRate = 1
end
on mouseLeave me
sprite(sVideo).visible = false
sprite(sVideo).movieRate = 0
sprite(sVideo).movieTime = 0
end
on mouseUp me
sprite(sVideo).movieRate = 0
sprite(sVideo).movieTime = 0
go to frame 20
1

1 Respuesta

274.425 pts.
¿Ese script lo tienes en un botón?
Entiendo lo que quieres hacer, lo que no entiendo es como.
Los loading en para proyectos en cdrom o para HD no son necesarios y la demora en aparecer se ocasiona solo por utilización de procesador, por lo tanto cualquier otra animación de LOADING también tardaría en aparecer.
Haré algunas pruebas y te cuento lo que descubra..
Saludos de nuevo.
He estado probando, y el problema está en el script. Si lo elimino, se acaban los problemas.
Sabiendo esto, aunque nunca se sabe con esto de los "1s y 0s", ¿qué puedo hacer para poder conseguir lo que pretendo -ese script de otra forma vamos-? Además ya te comento que en el ordenador en el que he creado el proyecto, el script funciona perfectamente tanto desde HD como desde CD.
Gracias.
Hola, siento ser pesado.
Sólo comentarte que ese mismo script, si en vez de video es un loop funciona bien -en vez de "global sVideo", "global Loop".
Por si te sirve.
Saludos.
Saludos.
Sobre la carga de película entiendo por tu respuesta que no es necesaria; luego ahí no está el problema.
Respecto a tu pregunta, te explico:
Es un proyecto para una compañía de teatro, y lo que hago es poner las obras que la compañía tiene en cartel. Entonces, hago un loop con elementos de cada obra (cada obra una por separado), y ese loop es el botón sobre el que aplico el script, para que cuando navegando se haga un mouseOver sobre ese loop-botón se vea el video correspondiente a esa obra, y así con las otras obras. Esa es la idea, y supongo que el script que he usado es el como. Ya te digo que el problema es al reproducir el .exe en otros ordenadores, porque en el que he realizado el proyecto, el .exe va sin problemas.
También puedo mencionarte, que he usado el xtra de video tabuleiro, por si eso tuviese algo que ver, aunque en el cd donde coloco el .exe, también coloco la carpeta de Xtras de Director donde lo instalé.
Espero tu ayuda como agua de mayo. Gracias mil.
No, no se ha solucionado. Solo que si no pongo el video el cd no se bloquea; pero eso no es una solución.
Si tienes alguna idea la agradezco.
Saludos.
Tal vez solo te falta definir el nombre de una variable. Si el problema se solucionó con eso, eso es.
C
¿De qué tipo son los videos? MOV, MPG, AVI?
C
MPEG 2, comprimidos desde AVI con "Main Concept MPEG Encoder" e importados a Director con el XTRA "Tabuleiro".
Saludos.
Estamos frente a un problema de "VER PARA ENTENDER".
He tratado de darle solución a tu problema pero no veo cual sea el problema.
No tengo el Xtra Tabuleiro y no se si tenga algún problema conocido.
Lamento no poder ayudarte.
C

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas