Problema de sonido con el proyector

Hola bedelludrica, estoy dando los últimos toques a mi proyecto y tengo un pequeño problema con el proyector con respecto al sonido. Uno de los juegos de mi proyecto presenta al usuario un cuento al que le faltan algunas palabras. Dichas palabras aparecen en una parte de la pantalla para que el usuario las coloque correctamente y, cuando lo hace, se escucha una voz que relata el cuento. El caso es que mi juego funciona perfectamente cuando se ejecuta desde director, pero cuando se utiliza el proyector, en algunos de los cuentos no se escucha el relato y el programa queda "atascado" durante unos segundos. Después continua adelante como si se hubiera escuchado el relato.
El relato es un archivo de sonido .aif externo. El nombre del archivo lo coloco en una variable local y lanzo el sonido en un script de la siguiente forma:
on exitframe me
global cuento, parte
archivo="M3" & cuento & parte & ".aif"
if the machinetype=256 then
sound playfile 7, "Audio\" & archivo
else
sound playfile 7, "Audio:" & archivo
end if
end
¿Sabes dónde podría estar el problema? Siempre ocurre con los mismos cuentos, pero como te he dicho antes, desde director funciona perfectamente. Donde falla es en el proyector.
Gracias de antemano por tu respuesta.
1

1 Respuesta

252.550 pts.
Esto tendría que verlo mejor.
Mandame un ejemplo a [email protected] y te lo corrijo.
¿Qué te envío exactamente? ¿La película?
¿Los scripts que intervienen en el asunto?
Dime por favor a lo que te refieres.
Bego
Mándeme un un trozo de la película donde te falle al crear el proyector.
Si es muy extenso mandame el código donde te falla lingo y lo analizo en un proyector.
Ya te he enviado la película. Espero no haber colapsado tu correo.
Bego
Estoy viéndolo
¿Has probado lo que te he dicho?

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas