Probleamas con simbolos en Crystal Report

Con una base de datos en MSSQL Server 2000 y Crystal 8.5, estoy generando un informe. El problema es que el informe me imprime incorrectamente los caracteres no comunes (acentos principalmente). Esto ocasiona que en el reporte, aparezca una letra Y (ye acentuada, que es un carácter griego creo) en lugar de una i acentuada, o cosas por el estilo. La configuración regional de Windows es la correcta, Español (Argentina).
En primer lugar me gustaría identificar el causante del problema, si se soluciona del lado de la base de datos o del lado de crystal. En una aplicación de VB, se lee perfectamente todo.
1

1 Respuesta

4.450 pts. Conocimiento en programación sobre VB, Informix 4gl
Realice algunas prueba y realmente no encontré solución a tu inquietud.
Te sugiero que coloques la pregunta nuevamente en el tablón para ver si otra persona sabe que es lo que esta pasando y te de una buena solución.
Me da pena no poderte ayudar pero como te decía no encontré la solución.
Te agradezco de todos modos por la preocupación.
Bueno esta como rara la cosa, pero vamos a ver que se puede hacer.
Tengo unas preguntas, ¿qué tipo de letra estas usando y la otra estos caracteres te aparecen solo con datos traídos de la base de datos o también cuando colocas un campo texto?
Puedes hacer la prueba de colocar un campo texto con letras acentuadas para ver si crystal los toma bien y me cuentas, con eso vamos detectando quien origina el cambio, si es crystal o es la base de datos.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas