Red con cable cruzado

Primero de todo no soy novato en esto de las redes porque llevo más de tres meses intentando que me funcione bien una.
El supuesto de hecho es: tengo dos ordenadores con W98 conectados por ethernet mediante un cable cruzado. En uno de ellos también tengo una conexión a internet mediante un cable-módem a un operdador de cable, MENTA. En algunas ocasiones he conseguido no sé como que funcionase bien la red, pudiendo conectarme a internet por el otro ordenador y escuchar canciones de mp3 sin cortes desde el ordenador donde no estaban archivados. Sin embargo ahora hace días que la red no me funciona bien tengo instalados los protocolos netbeui i tcp/ip para la red interna y el tcp/ip para la ethernet conectada al cable modem. Desde los dos ordenadores consigo ver al otro al que tiene su propio nombre, pero cuando intento abrir los archivos se cuelga la mayoría de las veces. Cada ethernet interna tiene su propia dirección y máscara de subred y están bien configuradas porque he leído miles de veces cómo se tiene que hacer.
Cuando hago pings entre ordenadores normalmente se pierde 1 paquete de los 4, aunque a veces llegan todos.
He probado a volver a instalar los protocolos o incluso windows muchas veces pero sigue sin funcionar como a veces ha llegado a funcionar.
Para especificarte más te diré que las ethernet de la red interna son una acer lan 325 10/100.
Una primera solución que encontré fue quitar los adaptadores de acceso telefónico a redes porque leí en las instrucciones del winproxy que podrían existir problemas con los drivers cuando se utilizaba un cable cruzado, y la cosa mejoró. Pero ahora ni así llega a ir bien del todo.
Después de divagar mucho he llegado a la conclusión de que tal vez pudiera ser cosa de las tarjetas de red pero hasta ahí ya no llego para entender cosas como el full-duplex y demás:
Cuando ejecuto el acerset la configuración que sale es la siguiente:
Ethernet adress ...(cada tarjeta con su respectiva
Network speed 100 Mbps
Full-duplex: enabled
I/O Base E000 H
Interrupt 2/9
Boot ROM size: No Boot rom size
Device/slot number:12
Bus number 0
Flow control: Rx disable Tx disable (No way control)
Medium type: Auto detect
Plug aux power: No.
Por último y para no molestarte más no se con que servicio iniciar el windows en cada ordenador; ¿Con el microsoft family, con el cliente para redes microsoft o con el simple windows?
Espero que los datos hayan sido suficientes y al que solucione mi problema estoy seguro que dios le tendrá un lugar especial en el paraíso!
1

1 Respuesta

5.050 pts.
Que sepas que te has explicado perfectamente, pero tal y como me cuentas, si se te queda colgado al intentar acceder a un equipo, el problema no es de configuración, sino lamentablemente de la tarjeta de red.
Puede haber dos causas: que una de las tarjetas de red esté defectuosa o haya sufrido algún problema, o que la IRQ que tiene asignada no funciona correctamente. Para ver esto, desde el panel de control, en Sistema, mira las propiedades de tu tarjeta de red desde el administrador de dispositivos, y en la pestaña de recursos mira la petición de interrupción (IRQ) que tiene asignada. Intenta cambiarla y reinicia, pero asegúrate de que no tenga ningún conflicto la nueva dirección IRQ (eso lo ves en el cuadro de debajo). Si te da algún problema al reiniciar, la irq estaba bien (si no te deja ni siquiera arrancar windows arranca en modo a prueba de fallos y vuelve a ponerle la IRQ original).
Y si estaba bien la IRQ... la tarjeta de red está defectuosa :(
Mira he averiguado un poco más y me he dado cuenta de que antes tenia las dos ethernets del ordenador conectado a internet con las mismas IRQ, ahora las he cambiado cambiando las tarjetas de sitio en la placa base y ahora tienen una IRQ distinta. Del modo que tu me has dicho no consigo cambiar la IRQ, me dice que no se puede modificar el valor de este recurso.
He cambiado las IRQ y sigue sin funcionarEn el caso de que fuera problema de la tarjeta de red, ¿cómo puedo saber cuál es la defectuosa (de las dos)? Y no podría ser también problema del cable cruzado, éste es larguillo de unos 30 m, ¿existe algún modo de comprobar si funciona?.
Finalmente te diré que ahora la IRQ de la ethernet conectada al cablemodem me coincide con la de la tarjeta gráfica, pero eso creo que no influye para nade en la red interna.
Muchas gracias Fido, pronto me pondré como experto en temas jurídicos que es lo mío, así que si algún día necesitas un consejo ya sabes. Gracias a esta web me he dado cuenta de que es posible que algún día no necesitemos del dinero para solucionar nuestros problemas
¡Hasta pronto!
Vamos a ver, el tema de las irq's lo tienes bien, pero lo que no me dijiste es que tienes un cable de... 30 METROS! Si no es un cable apantallado, es muy probable que pierdas información a consecuiencia de los llamados "ruidos", que son interferencias que recibe el cable.
Me inclino a pensar que es el cable porque como tú dices al hacer pings se pierden algunos paquetes y eso no debería ser. Para comprobar el cable, hay unos aparatitos que sirven precisamente para eso, que se conectan en ambos extremos del cable y emiten una serie de luces en función del estado de éste.
Pero si sólo lo quieres para comprobar tu cable, te sale mucho más barato hacerte un cable nuevo, que sea apantallado, y con el mínimo de longitud posible.
Respecto al inicio de sesión, que no te había contestado, utiliza simplemente el inicio de sesión en windows, ya que no tienes ningún servidor que autentifique passwords.
Perdona fido pero he estado de viaje y no he podido leer el mensaje hasta hoy, me has sido de gran utilidad y te agradezco enormemente tu ayuda.
Espero no volver a necesitar de tu ayuda aunque si así sucede será un placer.
Agradecido: Petxo

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas