.. ..

.. ..

 Colombia @87woh6pvbnb3f3wu desde - visto
Preguntar

Actividad pública reciente

Ha valorado "Excelente" la respuesta

Macro VBA que extraiga valores repetidos de dos rangos

respondió: Parece que se puede hacer con fórmulas. Teniendo seleccionado el rango W2:AF2, pega esta fórmula en la barra de fórmulas: =SI.ERROR(K.ESIMO.MAYOR(SI(NO(ESERROR(COINCIDIR(SI(A2:J2<>"";A2:I2);L2:U2;0)));A2:I2);COLUMNA()-22);"") y termínala pulsando...
Ha valorado "Excelente" la respuesta

Macro VBA para concatenar y sacar permutaciones de datos en diferentes rangos

respondió: El enfoque de esta macro es hacer la concatenación en memoria, de esa manera es más corta la macro y más rápida: Sub concatenar_permutaciones() Dim a As Variant Dim i As Long, j As Long, k As Long, m As Long, n As Long a = Range("A4:AD" & Range("A" &...
Ha valorado "Buena" la respuesta

Macro VBA para concatenar de acuerdo a una condición

respondió: Esto te puede ayudar https://macrosenexcel.com/macro-extrae-datos-en-base-criterios-y https://www.youtube.com/watch?v=G-z1YGjYgkk&list=PLdK9H5dMIfQhn9waYbEdu3DYAuBdSCIBx
Ha empezado a seguir a
Ha valorado "Excelente" la respuesta

Problema con VBA que extrae aleatorios de un Rango

respondió: Te cambio la macro por una nueva Sub Aleatorios() Dim i As Long, j As Long, n As Long, m As Long, r As Range Dim idx As Long, tmp As Variant, arr As Variant ' i = ActiveCell.Row Set r = Range("A" & i & ":AD" & i) n = WorksheetFunction.CountA(r) m =...
Voto positivo a la respuesta

Es D. Amor el creador de Todoexpertos?

respondió: H o l a ermacia, jaja no para nada, no soy el creador, el creado es Josep Planells Alòs. Solamente soy un usuario que me gusta ayudar, me apasiona encontrar la mejor solución y empeñarme hasta encontrar la respuesta para que estén satisfechos....
Ha valorado "Excelente" la respuesta

Modificar VBA de extraer números no repetidos de rangos

respondió: No lo vas a creer! Pero solamente tienes que modificar este número en la macro para obtener el número de repeticiones, si quieres los números que se repiten dos veces: If dic(ky) = 2 Then Si quieres los números que se repiten 3 veces, entonces cambia a 3.
Ha valorado "Excelente" la respuesta

VBA para extraer datos no repetidos de varios rangos

respondió: Observa como puse los rangos empezando en la fila 2, terminan en la última fila con datos de la hoja1. Por supuesto, puedes ejecutar la macro en cualquier otra hoja. Sub Extraer_No_Repetidos() Dim sh As Worksheet Dim dic As Object, ky As Variant,...