¿Cómo calcular horas nocturnas en una hoja de excel?

He estado buscando en los diferentes temas de todo expertos, pero no he conseguido encontrar una fórmula que realmente funcione. En algunos casos, las fórmulas devuelven 8 horas nocturnas cuando en realidad no hay ninguna, o "0" cuando sí las hay. Lo que busco es una fórmula para calcular las horas nocturnas (22:00-6:00) en cada turno. Si C2 es la hora de entrada, pongamos las 18:00, y C3 es la hora de salida, las 2:00, la fórmula debería devolver 4 horas nocturnas (esto es, entre las 22:00 y las 2:00). Lo mismo ocurriría si el horario es de 22:00 a 6:00 (8 nocturnas) o de 2:00 a 10:00 (4 nocturnas). Hasta ahora, las fórmulas funcionan en el primer supuesto, pero no en los otros dos, aunque no tengo muy claro cuál es el motivo... ¿Alguna idea sobre cómo resolver este problema?
1

1 Respuesta

98.350 pts. Usuario a nivel Intermedio/Avanzado de Excel
Usa esto por ejemplo
=SI(C2<24;24-C2+D2;D2-C2)
Y asegurate de poner el formato personalizado hh:mm y así tendrás lo que quieres.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas