¿Cómo montar un ftp con el 3Com?

No quiero enrollarme mucho, porque sino la pregunta puede llevar a konfusion, pero si alguien requiere una explicación más en profundidad se la puedo hacer.
Veamos, no creo que sea un problema de instalación, puesto que me funciona, tpk de confirguración, es una cuestión de que no abre realmente los puertos (al menos el 21).
Lo he hecho de varias formas, con el hyperterminal, mediante telnet, o el based-web que ofrece 3com (como se explica en el siguiente articulo)
http://www.principiantes.org/adsl/abrir_puertos_en_3com_812.htm
Si me pongo un modem, me va perfectamente (el ordenador tiene la ip publica), pero si pongo el router en multipuesto (en el que dicho router tiene la ip publica, y los ordenadores tienen ip's privadas), si monto el ftp me va en la intranet (si accedo a la ip privada), pero cuando accedo mediante la publica me sale el mensaje de que no se puede acceder a la carpeta (W2k), He probado con varios servidores, pero no creo que sea un problema de servidor, puesto que me va localmente, o si pongo un modem (lo cual no me interesa porque tengo varios ordenadores.
El caso es que mi confirguración lo permite, puesto que esta activo el ftp, tanto para direcciones locales, como para publicas si lo hago por modem.
Pero en cuanto monto multipuesto y es el router el que tiene la ip publica, aunque el programa del 3Com me diga que esta abierto, lo cierto es que no lo abre. ¿Puede ser un problema hardware?.
Kabe citar ke la firmware es la ultima, asi ke tpk kreo ke sea ese el problema.
1

1 Respuesta

9.100 pts.
Estando tu 3com en multipuesto y teniendo el servidor ftp en un ordenador de la red, tendrás que redirigir el puerto 21 del router al puerto 21 de tu ordenador local, esto lo puedes hacer con el hyperterminal (que es el que tú estas usando) con las siguientes instrucciones:
1.- Disable vc internet
2.- Add nat tcp vc internet public_port 21 private_address 192.168.0.1
private_port 21
3.- set vc internet nat enable
4.- Enable vc internet
Te comento un poco cada instrucción:
1.- Deshabilita VC para que el router nos deje hacer cambios.
2.- Le indicamos que todo lo que vaya dirigido al puerto 21 en nuestra ip pública, lo redirija al puerto 21 de un ordenador de nuestra red local privada (en este caso he puesto 192.168.0.1, así que tendrás que sustituir esta IP por la de tu ordenador local)
3.- Habilitamos NAT para que el router proceda a realizar las redirecciones.
4.- Volvemos a habilitar VC para volver a tener conexión.
Haz esto, y una vez comprobado que todo funciona bien, no te olvides de poner un último comando:
Sabe all
Para grabarlo todo y se quede configurado, de lo contrario, si no pones esto último, como tu router se reinicie o tenga un corte de corriente, tendrás que volver a reconfigurarlo.
A ver, eso ya lo he hecho, como comentaba en la pregunta, no solo lo he hecho por hyperterminal, sino por telnet o "based-web".
El problema debe ser otro, (tal vez hardware). Pero gracias por tu respuesta.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas