Búsqueda no me devuelve valor en foxpro

Tengo un formulario de búsqueda de items que ingresa registro a un grid, cuando ingreso un registro todo funciona bien pero cuando a buscar otro no me lo registra solo pasa esto en text que enfoca cuando lo muevo de hay todo funciona bien. Uso este código para llamar el form de búsqueda

 _desdefacturacion = 1
m.retorno = 0
m.referencia = ' '
thisform.codigoanterior = 0
thisform.seleccionar = 0
DO FORM busca_producto.scx
IF EMPTY(m.retorno)
thisform.ventas.column1.setfocus
cierra ('configuracion')
RETURN 0
ENDIF
thisform.seleccionar = 1
SELECT (thisform.detalle_factura)
IF RECNO()>0 .AND. .NOT. EMPTY(codpro)
APPEND BLANK
ENDIF
SELECT (thisform.detalle_factura)
REPLACE codpro WITH STR(m.retorno)
thisform.ventas.column1.codigo.value = STR(m.retorno)
Thisform. Ventas. Column1. Codigo. Lostfocus()
Thisform. Ventas. Column5. Setfocus
Thisform. Ventas. Refresh()
MRETO = 1 

1

1 Respuesta

57.100 pts. Programación, hardware, configuraciones, temas...

No alcanzo a comprender mucho lo que dices Plácido, pero si es un problema de refresco; pon al final un Thisform. Refresh()

Utilice el refresh y no funciona al parecer cuando recibe el enfoque me bloquea que se registren más items porque cuando me muevo del text todo vuelve a la normalidad

No puedo decirte nada al respecto Plácido con la información con que cuento.

Pero si al cambiar de objeto se resulve; deberías revisar lo que hace esto...

Thisform. Ventas. Column1. Codigo. Lostfocus()
Thisform. Ventas. Column5. Setfocus

En uno de los 2 debe estar la respuesta.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas