Usar DÍAS.LAB dentro de fórmula matricial

Tengo un nuevo problema. Tengo la siguiente fórmula matricial:
=promedio(si(c2:c5="a";si(mes(b2:b5)=7;b2:b5-a2:a5)))
Los datos fuente son:
Fec.Inicio Fec.Fin Tipo
13/05/2010     24/05/2010    A
12/04/2010     28/06/2010    C
11/05/2010     10/07/2010    B
23/06/2010     09/07/2010    A
Debo reemplazar la resta de fechas (la que figura en negrita en la fórmula) por una resta de fechas que obtenga los días laborables no los calendarios. Entonces he intentado reemplazar esta resta de fechas por DÍAS.LAB pero parece que esta función no va con fórmulas matriciales. ¿Cómo creéis que lo podría resolver?
=promedio(si(c2:c5="a";si(mes(b2:b5)=7;dias.lab(b2:b5;a2:a5))))
Gracias por cualquier solución que me pudierais dar.
1

1 Respuesta

222.425 pts.
Si te sirve esta fórmula matricial que resta el número de sábados y domingos antes de calcular el promedio:
=PROMEDIO(SI(C2:C5="A";SI(MES(B2:B5)=7;B2:B5-A2:A5-(ENTERO((B2:B5-DIASEM(B2:B5)-A2:A5+8)/7)+ENTERO((B2:B5-DIASEM(B2:B5-6)-A2:A5+8)/7)))))
Pero pruébala a fondo porque no estoy seguro de que funcione siempre bien, aunque parece que sí calcula bien con los datos del ejemplo.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas