Agregar Puntos y Guion a un Rut en Excel

Quiero una fórmula una macro o, un textbox(insertado en la hoja), o cualquier cosa que al escribir un rut ya sea terminado en"K" (12123123-k) lo deje así (12.123.123-k)

6 Respuestas

Respuesta
3
Puesdes utilizar esta formula =CONCATENAR(EXTRAE(P1;1;2);".";EXTRAE(P1;3;3);".";EXTRAE(P1;6;3);"-";"K"), cualquier duda, no dudes en consultarme
Hola Gracias por responder,
Muy bien existe un problema:
Usé tu fórmula funciona muy bien si el RUT termina en "K" (17491683k)
Pero si si termina en un numero no funciona (174916837) debiese quedar así "17.491.683-7"
Aquí más ejemplos de rut y de como debiesen quedar
9123123k -----> 9.123.123-k
19123123k------>19.123.123-k
71231233 -------> 7.123.123-3
171231237 ------> 17.123.123-7
Gracias espero una solución
Saludos atentamente Diego
Pues bien
Pensé que QUE era un valor fijo, por eso te coloque QUE, pero siendo una variable, coloca los siguiente:
=CONCATENAR(EXTRAE(P1;1;2);".";EXTRAE(P1;3;3);".";EXTRAE(P1;6;3);"-";EXTRAE(P1;7;1).
Tu dirás como funciona.
El Extrae, como su nombre lo dice extrae un carácter o varios de una celda en especifico, P1 significa la celda donde vas a extraer la información, 6 es la posición inicial en que se encuentra lo que vas a extraer y 1 es la cantidad de caracteres que se van a extraer.
Espero te haya de sido de gran ayuda. No se te olvide calificar la respuesta.
No me funciono, tuve que modificar el final así:
=CONCATENAR(EXTRAE(P1;1;2);".";EXTRAE(P1;3;3);".";EXTRAE(P1;6;3);"-";EXTRAE(P1;9;1))
Ahora funciona bien cuando los rut son así 12.123.123-x necesito que cuando sean de así 1.123.123-x (un dígito menos)
Debe poderse con una condición SI y blabla xD
Saludos
Bueno prueba con esto:
=si(largo(l3)=9;concatenar(extrae(l3;1;2);".";extrae(l3;3;3);".";extrae(l3;6;3);"-";extrae(l3;9;1));concatenar(extrae(l3;1;1);".";extrae(l3;2;3);".";extrae(l3;5;3);"-";extrae(l3;8;1)))
Respuesta
2

Un informático me dio una fórmula más precisa y simple

=CONCATENAR(TEXTO(EXTRAE(A2;1;LARGO(A2)-1);"#.#.#");"-";DERECHA(A2;1))

A mi me resultó.

Respuesta
1

A mi me funcionó de la siguiente manera:

=SI(LARGO(A1)>7;CONCATENAR(EXTRAE(A1;1;2);".";EXTRAE(A1;3;3);".";EXTRAE(A1;6;3));CONCATENAR(EXTRAE(A1;1;1);".";EXTRAE(A1;2;3);".";EXTRAE(A1;5;3)))

De esta forma, puedo colocar los puntos de millar en números de cedula de identidad (Venezuela)

Respuesta

Acá está la función arreglada y probada:

=si(largo(a1)=10;concatenar(extrae(a1;1;2);".";extrae(a1;3;3);".";extrae(a1;6;3);"-";extrae(a1;10;1));concatenar(extrae(a1;1;1);".";extrae(a1;2;3);".";extrae(a1;5;3);"-";extrae(a1;9;1)))=si(largo(a1)=10;concatenar(extrae(a1;1;2);".";extrae(a1;3;3);".";extrae(a1;6;3);"-";extrae(a1;10;1));concatenar(extrae(a1;1;1);".";extrae(a1;2;3);".";extrae(a1;5;3);"-";extrae(a1;9;1)))

Respuesta

Aquí les dejo una alternativa que funciona con los RUT chilenos.

=si(largo(d3)>9;concatenar(extrae(d3;1;2);".";extrae(d3;3;3);".";extrae(d3;6;3);extrae(d3;9;2));concatenar(extrae(d3;1;1);".";extrae(d3;2;3);".";extrae(d3;5;3);extrae(d3;8;2)))

Respuesta

Aquí tienes una solución:

=Concatenar(texto(izquierda(A1;largo(A1)-1)*1;"#.#");"-";derecha(A1;1))

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas