Función SI - Dos pruebas lógicas para operar

Agradecería a quien de vosotros conozca la solución me echara una mano. Tengo el siguiente problema:
¿Cómo se puede conseguir que en una celda se "opere", si se dan DOS pruebas lógicas a la vez, una y otra?
Pongo un ejemplo:
Fecha 1: 01/01/2000
Fecha 2: 01/01/2004
TABLA
01/01/2000 - 31/12/2000
01/01/2001 - 31/12/2001, así sucesivamente.
Supuesto:
Aplicar una determinada operación si:
a) La fecha 1 es mayor o igual que el extremo inferior del intervalo, en este caso, mayor o igual que 01/01/2000 y también se da que;
b) La fecha 2 es menor o igual que el extremo superior.
En definitiva, que calcule cuando las fechas 1 y 2 se encuentren DENTRO de alguno de los intervalos de la TABLA.
1

1 Respuesta

305.350 pts. * Bachiller en Ingeniería Industrial
Bueno es verdad, se tiene que emplear una fórmula condicionada, la cual no sera nada sencilla la fórmula. Pero antes hagamos una tabla, un esquema en Hoja1. Escribe los siguientes valores en la disposición que se muestra:
    A | B |
1 | F1 | 01/05/2002
2 | F2 | 11/12/2002
*
*
6 | 01/01/2000 | 31/12/2000 | Peru
7 | 01/01/2001 | 31/12/2001 | Colombia
8 | 01/01/2002 | 31/12/2002 | Argentina
9 | 01/01/2003 | 31/12/2003 | Mexico
10 | 01/01/2004 | 31/12/2004 | Uruguay
*****
La idea es que si esta dentro del rango que me devuelva el país correspondiente:
Imaginemos que la fórmula la quiero establecer en F6, entonces en dicha celda indicar esta fórmula:
=SI(Y(NO(ESERROR(BUSCAR(B1;A6:A10;C6:C10)))=VERDADERO;B2<=INDICE(B6:B10;COINCIDIR(BUSCAR(B1;A6:A10;C6:C10);C6:C10;0);1)=VERDADERO);BUSCAR(B1;A6:A10;C6:C10);"")
El resultado del ejemplo devolverá Argentina. Si no esta dentro del rango devolverá el vacío. Probado y demostrado previamente. Espero haberte ayudado.
NO olvides de finalizar y puntuar la respuesta ofrecida al final de esta página.
Estimado Christian, estoy infinitamente agradecido por tu respuesta. Sin embargo, no consigo hacer lo que necesito. Piensa que en el momento en el que tienen distintos años, ya no funciona:
Fecha 1: 01/07/2000
Fecha 2: 01/07/2005
Días: 1.826
TABLA
01/01/2000 31/12/2000     181     Opera
01/01/2001 31/12/2001     365     Opera
01/01/2002 31/12/2002     366      Opera
01/01/2003 31/12/2003     365      Opera
01/01/2004 31/12/2004     365      Opera
01/01/2005 31/12/2005      181     Opera
01/01/2006 31/12/2006     365      No hace nada o devuelve "Cero"
Lo que necesito es que cuando no haya coincidencia entre el rango de fechas (1 ó 2), no opere. En el ejemplo expuesto, cómo la Fecha1 está en el rango de 01/01/2000 -- 31/12/2000, pues operaría con el dato 181. Así sucesivamente, pero con el límite de la Fecha2, en la que se acaba la serie y aplicaría entonces el 181. Por último en 01/01/2006 -- 31/12/2006, no haría nada al estar fuera de las fechas propuestas.
A fin de cuentas, se trata de que "desglose" la diferencia de DÍAS, en CUALQUIER PERIODO, ya sea AÑOS, SEMESTRES, TRIMESTRES, etc.
La explicación es que luego se le aplica un TIPO DE INTERÉS, en función de QUE PERIODO ESTEMOS, tipo que va cambiando, según el semestre, trimestre o año de que se trate.
Disculpa si es un poco enredoso, pero llevo mucho tiempo queriendo desglosar un número de días en periodos distintos: años, semestres, trimestres, meses, y no hay manera.
Muchísimas gracias y un fuerte abrazo, SIMON
De nuevo simon300!
Seré muy honesto. Al leer de nuevo tu replica me has confundido. Hasta donde comprendí los valores que están acotados por fechas iniciales y finales de cada año son los intervalos que serán los evaluados por la fórmula. En mi ejemplo (si puedes echar un vistazo) inicie desde el 2000 y termine en el año 2004, por tanto tiene 5 intervalos.
Otra cosa que comprendí es que los valores almacenados en B1 y B2 que representan FECHA 1 y FECHA 2 respectivamente son fechas también, inicial y final. La idea era que estas dos fechas corresponden o "Pertenecen a" uno de los 5 intervalos antes mencionados.
El ejemplo inuitivo que hice es muy claro. 01-May-2002 y 11-Dic-2002. La amplitud de estas dos fechas PERTENECEN al 3er intervalo y me debería devolver Argentina.
Estoy aumentando en mi ejemplo un 6to intervalo para Paraguay que es para el año 2005. Cambio la fórmula un poco en las referencias y aun funciona.
******
Lo ultimo me confunde dado que exactamente no era el planteamiento original. Por favor realiza el ejemplo si no lo has hecho. Favor avisar alguna aclaración concerniente a la fórmula si la hubiese.
O en su defecto, aclarame explícitamente el caso si estaba confundido inicialmente.
Saludos
Christian
[email protected]
Para comunicarte que acabo de enviarte el archivo con la observación subsanada!
Revísalo detenidamente.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas