Instalación de samba 3.3.9 en FreeBSD 6.1

Tengo una maquina virtual con FreeBSD 6.1. Entro como administrador y me voy al directorio /usr/ports/net/samba33. Ejecuto make y me da el siguiente error: "X11BASE is now deprecated. Unser X11BASE in make.conf and try again" Error code 1.
¿Qué puede estar pasando?
Gracias.
Saludos.
{"lat":39.9097362345372,"lng":-3.69140625}
1

1 Respuesta

2.700 pts.
Todo parece indicar que utiliza unas librerías que deben ser antiguas y ya no están soportadas, prueba de hacer lo que te pide:
Edita el fichero make. Conf y localiza donde aparezca el X11BASE, revisa que no aparezca la definición de X11BASE, si quieres (y si no es muy largo) pégame aquí el contenido del fichero e intentamos revisarlo.
Soy principiante en freebsd. Donde puedo localizar el fichero make. ¿conf?
Saludos.
El make. Conf es el fichero de configuración de la compilación, según lo que tengas en ese fichero es posible que te cambien las opciones del programa que compiles, o que no te compile directamente. Este fichero lo puedes encontrar en el directorio donde tengas el código fuente del samba, en tu caso según el post: /usr/ports/net/samba33/
No me aparece el fichero make.conf. A nivel raíz aparecen:
Makefile
distinfo
Files (directorio)
pkg-descr
pkg-plist
pkg-plist.swat
En el directorio files:
README.FreeBSD, patch-Makefile.in, patch-configure.in, patch-include__libreplace_cc.M4, patch-M4__aclocal.M4, patch-nsswitch__winblind.c, patch-nsswitch__wins_freebsd.c, patch-script__tests__dlopen.sh, patch-smbd__aio.c, patch-smbd__quotas.c, patch-smbd__statvfs.c, patch-utils__net_time.c, pkg-deinstall.in, pkg-install.in, pkg-message.in, samba.in, smb.conf.sample.in
Saludos.
Busca alguna posible referencia de la librería X11BASE en el Makefile y elimínala (recomiendo hacer una copia de seguridad del fichero :) ). Después prueba de compilarlo de nuevo.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas