Videos en director

Estoy realizando un interactivo con un número elevado de videos en Director MX. Muchos de ellos son de un móvil con una acción continua en loop hasta que se acciona un botón que da entrada a otro video con una acción diferente del móvil. Es necesaria una perfecta continuidad de los movimientos. El problema es que, aunque están todos los videos cargados en memoria cuando se acciona el botón y el primer video pasa del loop al segundo video hay una pequeña parada en la continuidad. También se nota un pequeño parpadeo en negro en el salto entre los videos ¿Esto es inevitable o es que no estoy utilizando las opciones adecuadas? Gracias por adelantado
1

1 respuesta

Respuesta
1
Perdona que haya tardado en responder.
El problema con los vídeos es el tiempo de carga. Si tienes vídeos que ocupan mucho vas a notar siempre un pequeño corte entre la reproducción de uno y el siguiente. En tu caso los vídeos deben tener todos el mismo color de fondo, y el mismo ancho y alto.
Asegurate de tener activada la opción DTS (Direct To Stage) del inspector de propiedades, en la pestaña correspondiente al video. Ahí estará la opción de Loop también. Con DTS lo que haces es mostrar el vídeo directamente en el escritorio encima de todo lo demás. Cualquier cosa que haya encima o debajo del vídeo no se va a ver. Esto ayuda mucho a la hora de reproducir vídeos haciendo que vayan más fluidos. Si desactivas esa opción, al cambiar de un vídeo a otro se nota el parpadeo que comentas. Con esta opción activada, si tienes los dos vídeos en la misma posición y tienen el mismo fondo, no se va a notar parpadeo. Si se va a notar un pequeño momento en el que se cambia de vídeo donde la imagen permanece parada.
Para evitar problemas en la carga de los vídeos, juega con las opciones Preload y Unload. Los vídeos que se muestren muchas veces no los descargues de la memoria nunca.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas