Problema con función SiInm (Access 2007)

Tengo una duda con respecto a la función SiInm, os cuento un poco de que va primero y así os hacéis una idea de esto.

He creado un formulario el cual realiza distintos tipos de cálculos, estos cálculos se hacen en un cuadro de texto, y a su vez dependen de distintos cuadros de lista. Hasta aquí la historia marcha bien, el problema es el siguiente:

En Este cuadro de texto pretendo al menos hacer 5 distintas consultas, solo que cuando añado una nueva me genera error de sintaxis, o sino, simplemente no lo copia, os muestro las ecuaciones a ver si me podéis decir donde está el error!

Ecuación simple y funcional:

=SiInm([cmb_part_type] Como "Capacitor*",(([Applied_
Voltage_Stress]/[Rated_Voltage])/[Constant_Function_of_part_type_S1])^[Constant_Function_of_part_type_n],SiInm([cmb_part_type] Como "Diode*",(([Vs_Default]^2.43)/0.185)))

Ecuación con errores:

=SiInm([cmb_part_type] Como
"Capacitor*",(([Applied_Voltage_Stress]/[Rated_Voltage])/[Constant_Function_of_part_type_S1])^[Constant_Function_of_part_type_n],SiInm([cmb_part_type]
Como "Diode*",(([Vs_Default]^2.43)/0.185))),SiInm([cmb_part_type]
Como "Thyristor*",(( [Voltage_Applied_Reverse]/
[Voltage_Rated_reverse])^1.9)/0.26))),SiInm([cmb_part_type] Como
"Transistor*",(0.21*(2.718^(0.31*( [VCE_Applied]/ [VCE_Rated]))))

No se que estoy haciendo mal, pero como podéis ver, mantengo el mismo formato de la versión simple, he hecho pruebas con el separador de lista y nada, no va por ahí, no se a que se refiere con errores de sintaxis cuando cumplo con las mismas del caso anterior... Esto me pasa con dos cuadros de texto adicionales que tengo...

Respuesta
1

O estoy muy dormido esta mañana (que podría ser) o creo que tienes un pequeño lío de paréntesis:

SiInm(
----[cmb_part_type]
Como "Capacitor*",
----(([Applied_Voltage_Stress]/[Rated_Voltage])/[Constant_Function_of_part_type_S1])^[Constant_Function_of_part_type_n],
----SiInm(
--------[cmb_part_type] Como "Diode*",
--------(([Vs_Default]^2.43)/0.185))), <-- sobra un
paréntesis de cierre (abres 2, cierras 3)
--------SiInm(
------------[cmb_part_type]
Como "Thyristor*",
------------((
[Voltage_Applied_Reverse]/ [Voltage_Rated_reverse])^1.9)/0.26))), <-- sobran 3 paréntesis de cierre (abres 2, cierras 5)
------------SiInm(
----------------[cmb_part_type]
Como "Transistor*",
----------------(0.21*(2.718^(0.31*( [VCE_Applied]/
[VCE_Rated] <--
Faltan 4 paréntesis (abres 4, no cierras ninguno)
------------)
--------)
----)
)

Hola amteipei,

Muchísimas gracias por tu pronta respuesta, pero resulta que he tenido que modificar las ecuaciones ya que tenía un error en un cálculo, pero he intentado lo que me has dicho y sigo en la misma situación, te anexo nuevamente las ecuaciones a ver si me puedes echar un cable con ello...

Ecuación Funcional

=SiInm([cmb_part_type] Como "Capacitor*",(([SA].[Valor]/[Constant_Function_of_part_type_S1].[Valor])^[Constant_Function_of_part_type_n].[Valor]),SiInm([cmb_part_type]
Como "Diode*",(([Vs_Default]^2.43)/0.185))),

Ecuación Con error
=SiInm([cmb_part_type] Como
"Capacitor*",(([SA].[Valor]/[Constant_Function_of_part_type_S1].[Valor])^[Constant_Function_of_part_type_n].[Valor]),SiInm([cmb_part_type]
Como "Diode*",(([Vs_Default]^2.43)/0.185)),SiInm([cmb_part_type] Como
"Thyristor*",(([Vs_Default]^1.9)/0.26)), SiInm([cmb_part_type] Como
"Transistor*",(0.21*(2.718^(0.31*( [VCE_Applied]/ [VCE_Rated]))))

Muchísimas gracias por tu ayuda!

Héctor!

El lío de paréntesis es parecido al anterior (si interpreto bien la fórmula, que ya te digo que tengo un día algo "espeso" hoy)Prueba con:

=SiInm(
[cmb_part_type] Como "Capacitor*",
(([SA].[Valor]/[Constant_Function_of_part_type_S1].[Valor])^[Constant_Function_of_part_type_n].[Valor]),
SiInm(
[cmb_part_type] Como "Diode*",
(([Vs_Default]^2.43)/0.185),
SiInm(
[cmb_part_type] Como "Thyristor*",
(([Vs_Default]^1.9)/0.26),
SiInm(
[cmb_part_type] Como "Transistor*",
(0.21*(2.718^(0.31*( [VCE_Applied]/ [VCE_Rated]))))
)
)
)
)

Hola amteipei,

Muchiiiiiiiiiiiiiisimas gracias por tu ayuda, has resuelto el problema que tenía, funciona muy bien....

Una cosita antes de cerrar esta pregunta, como hago para que cuando abra el formulario, los cálculos anteriores no queden almacenados?...

Saludos y hasta pronto..

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas