Calcular Precio medio ponderado

Buenos días, quisiera saber que función tengo que utilizar para calcular el precio medio ponderado dependiendo del texto en celda contigua. Es decir si en la columna A tengo diferentes nombres, en la B las unds. Y en la C el precio unitario, quiero que con un nombre concreto en la columna A, me multiplique la celda b1 por la c1, la sume a b2 por c2 y la divida por la suma de B. ((b1*c1)+(b2*c2))/(b1+b2)
La función que utilizo es esta:
=SUMAPRODUCTO(C2:C41="HPL-210";D2:D41;E2:E41)/SUMAR.SI(C2:C41;"HPL-210";D2:D41)
El valor que sale es cero y en todas las celdas hay valores
Gracias.

1 respuesta

1
Respuesta de
Hola:
Creo que lo que quieres es el precio medio unitario de varios productos si se da una condición como verdadera.
He encontrado la forma de hacerlo, toma el ejemplo de la estructura puesto que la ubicación de diferentes celdas es libre, pero te propongo lo siguiente:
En una celda pones el nombre que quieres que se localice en el rango.
Valor buscado xxx
                  VALOR A BUSCAR CANTIDAD PRECIO
fórmula 1 hola 2 2
Fórmula adiós 3 1
Fórmula ven 4 3
Autosuma de fórmulas fórmula
Fórmula 1 : =SI(B17=B$16;1;"")  Ten en cuenta que las he realizado sin tener en cuenta el comienzo de la hoja, te lo digo para que ajustes el nº de celda.
Fórmula 2: =SI((A22<>"");((C17*D17)+(C18*D18)+(C19*D19))/SUMA(C17:C19);"")
En este caso el precio medio ponderado es 2,11
Espero haberte ayudado
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje