Restar y sumar columnas en excel

Respuesta de
a
Usuario
Hola amigos de todoexpertos.
Mi problema es el siguiente:
Tengo una hoja en excel con las siguientes columnas: A1:entrada -B1: salida - C1:saldo- D1:total. En la entrada y salida realizo una resta que es reflejada en la columna saldo fórmula es =(A2-B2), esta fórmula la arrastro hasta la celda que me es más conveniente para realizar las siguientes operaciones de restas, lo que hay en saldo lo voy sumando para reflejar el resultado en el total, primero sumo las celdas de la columna saldo =(C2+C3) luego sumo =(C4+D2) para el total, todo funciona bien. Ejemplo.
Entrada salida saldo total
100 50 50 150
200 100 100 250
300 200 100 300
100 50 50 300
                                        0 300
                                         0 300
                                         0 300
Mi pregunta es la siguiente: se puede hacer algo para que no se repitan los datos del saldo (0) y del total (300), sin tener que quitar las fórmulas de las celdas restantes, para que al ingresar más datos se haga automáticamente como en el ejemplo, una forma elegante lo llamaría. Espero que me entiendan, muchas gracias amigos de todoexpertos, espero respuestas.
 
Avatar
Experto
Hola, mañana te respondo
Avatar
Experto
Hola, lo que debes hacer es añadir a tu fórmula una sentencia condicional, es decir un si,
si a1<>"" entonces ...
De forma que si no hay ningún dato de entrada (por ejemplo) no se ejecuta la fórmula, y los datos de las otras celdas no aparecen
Saludos
Usuario
Hola amigo de todo experto, la condicional SI hace lo mismo que la fórmula anterior, igual quedan los números repetidos en las celdas que no se han llenado como en el ejemplo. Se podrá hacer algo para no tener que arrastrar la fórmula a las demás celdas para que no se repitan los números, ¿alguna macro?. Gracias todoexpertos.
Usuario
Hola de nuevo, sabes lo mejor sería quitar el total y que en saldo fuera apareciendo el total Ejemplo:
Entrada salida saldo
100 50 50
200 100 100
                           150
Me ayudarías a resolver mi problema. Muchas gracias amigos de todoexpertos.
Avatar
Experto
Hola, necesito ver las fórmulas de ambas celdas
Saludos
Usuario
Hola, ahí está el problema no se como plantear las fórmulas patra que me den la resta de la entrada y salida y lo sume en la columna saldo como en el ejemplo.
Avatar
Experto
ahh, ahora te pillo. Mira, la fórmula seria la siguiente:
=SI(A2<>"";(A2-B2)+C1;"")
ES PARA LA LINEA 2, la linea 1 debe permanecer vacía, ya que la columna total, suma la columna inmediatamente superior, si utilizáramos la linea 1, daría error, pues no existe una linea superior, digamos que la columna c1 debería contener el valor inicial del total, por defecto 0.
Saludos.
Por cierto, la fórmula es SOLO para la columna de total, en las demás no hay que introducir ninguna fórmula.
No te olvides cerrar la pregunta.
Usuario
Hola amigo de todo experto, excelente respuesta. Miles de gracias para ti. Gracias por dedicar tu tiempo para resolver mi problema.