Rubén Abella

Rubén Abella

 Reino Unido @ruchigol desde - visto
Preguntar

Actividad pública reciente

Ha preguntado en el tema en

Pasar de una matriz situada en celdas dentro de excel a VBA

Hola a todo el mundo!! Necesito hacer un programa para calcular unos parámetros concretos y para ello tengo que empezar por pasar los datos o terminos de una matriz en excel a VBA. En mi caso tengo una matriz de 97 filas y 97 columnas en excel, donde...
Sin respuestas
Ha preguntado en el tema en

Buscar valores dentro de una matriz excel y VBA

Hola Necesito ayuda, porque no se como realizar un programa en VBA que me busque dentro de una matriz una secuencia de unos seguidos en la misma diagonal. Para ello mi hoja de calculo consta de 70 matrices que pueden cambiar de valores dependiendo...
Sin respuestas
Ha valorado "Excelente" la respuesta

Reducir una fila para que no contenga 0

respondió: No creo que haga falta una macro, prueba poniendo la siguiente fórmula: =SI.ERROR(INDICE(1:1;;K.ESIMO.MENOR(SI($A1:$CV1<>0;COLUMNA($A1:$CV1));COLUMNA()));"") En la columna A de cualquier fila vacía. Si la copias hacia la derecha y hacia abajo...