Programación

6.743 seguidores
Preguntar

Preguntas resueltas

Pregunta en y en 1 temas más de

Bat para renombrar contenido solo de sub carpetas

Necesito una gran ayuda. En mi máquina tengo muchos archivos desordenados y quisiera saber si algo como lo que planteo a continuación es posible de implementar. Necesitaría un bat que renombre largas cantidades de archivos con las siguientes...
Pregunta en y en 4 temas más de

Application.ConvertFormula en una parte de la fórmula

¿Alguna manera de convertir la fórmula en celdas relativas a absolutas? Pero por partes, ejemplo: =BUSCARV($B$12;'[Lista 01.xlsx]Hoja1'!A5:B7;2;FALSO) $B$12 = esta primer parte quede en B12 pero la segunda parte A5:B7 = pase a A$5:$B$7 Con la...
Pregunta en y en 3 temas más de

Obtener dirección completa de rango en inputbox

Quisiera pode optener la dirección completa de un rango obtenido por inputbox ejemplo: Sub test() Dim wb As Workbook Dim saveFile As String Dim WorkRng As Range Dim address As String Dim defult As Integer Dim myString As String 'myString =...
Pregunta en y en 3 temas más de

Importar datos de varios libros

Dispongo de una macro que importa datos específicos de diferentes libros en la misma carpeta, los cuales se los asigna en una hoja de control y lo copia al libro activo, lo que quisiera es poder hacer que tome los valores de ubicación mediante vba....
Pregunta en y en 3 temas más de

¿Cómo podría buscar, comparar y pegar un valor en lista?

Hace tiempo que tengo esa incógnita de saber como podría, buscar un nombre en una lista, compararla con otra que puede o no estar en el mismo orden y pegar los valores que tiene al lado de cada nombre mediante vba. Tendría que ir buscando todos los...
Pregunta en y en 1 temas más de

Macro para traducir de ingles a español o viseversa

Que tal amigos tengo una pregunta hay forma de una macro para traducir del ingles al español o del español al ingles
Pregunta en y en 3 temas más de

No permitir duplicidad de datos

Sres. T. E. Tengo el Siguiente Código, el cual no me funciona como lo deseo. La idea es la siguiente: No permitir la duplicidad de dados de los primeros Cuatro(4) caracteres, como pueden observar en la instrucción “FindItem = Mid(Target, 1, 4)”...
Pregunta en y en 2 temas más de

Macro copiar de libro con fecha variable vba

Tengo la siguiente macro que copia una hoja de un libro con fecha variable en el nombre y lo pega en otro libro. No puedo resolver darle la instrucción que la fecha del archivo de origen de los datos va cambiando. Esto es lo que tengo (2022_07_16...
Pregunta en y en 3 temas más de

Buscar datos en un txt desde excel

Tengo un archivo en notepad de un peso aproximado de 3 MB, es una base de datos de todos los códigos postales de México, lo que quiero es que si yo capturo un código postal en "a1" si le doy click en "boton" buscar, me arroje la comunidad y estado....
Pregunta en y en 2 temas más de

Generar mediante marco meses en Excel

Tengo en la casilla C5 una determinada fecha (mes y año) y quiero que al introducir la fecha en esa casilla automáticamente mediante macro me genere a partir de la celda G6 seis meses anteriores, pero comenzando por el segundo mes. Es decir si la...