¿Como sumar las celdas y automático para macro?

Tengo dos ejemplos

EJEMPLO1 que suma F7:F10 y colocar la función =SUMA(F7:F10)

Y la siguiente EJEMPLO2 que suma F12:F20. 

Aqui tengo hacer sumar total horas la columna F

Para crear un macro que suma los valores y colocar cada uno

1

1 Respuesta

4.703.150 pts. Sancho, si los perros ladran ...

Te anexo la macro

Sub Macro5()
'Por Dante Amor
    ini = 7
    fin = Range("F" & Rows.Count).End(xlUp).Row
    For i = ini To fin + 1
        If Cells(i, "F") = "" Then
            Cells(i, "G").FormulaR1C1 = "=SUM(R" & ini & "C[-1]:R" & i - 1 & "C[-1])"
            ini = i + 1
        End If
    Next
    MsgBox "Fin"
End Sub

Cambia el 7 por el número donde empiezan tus datos.


.

.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas