Necesito una fórmula para resta en excel

Tengo esta fórmula =SI(AT1-7<=-1;"X";AT1-7) pero cuando el valor es cero en la celda AT1 me coloca X, y lo que quiero es cuando se realice la resta tome el valor de cero como un diez para que esto se pueda solucionar

3

3 Respuestas

551.900 pts. Si no valoras las respuestas, no esperes que te...

Que conste que no tengo ni idea de Excel pero lo poco que sé me dice que deberías poner

=SI(A1-7=0;10;SI(A1-7<=-1;"X";A1-7))

82.375 pts. Ingeniero Industrial, docente universitario de...

Si toma el valor de 10 hay que reemplazar

AT1 por

SI(AT1="";10;AT1)   ... supongo que en ambos casos....

en resumen;

cambias

=SI(AT1 - 7<=-1; "X"; AT1 - 7) 

por

=SI( SI(AT1=""; 10; AT1) - 7<= -1; "X", SI(AT1="";10; AT1) -7)

Experto jaime muchas gracias funciono añadiéndole el ; al tercer SI quedaría así

=SI(SI(AT1="";10;AT1)-7<=-1;"X";SI(AT1="";10;AT1)-7)

Experto cuando tengo un numero como el 9 en la celda AT1 y realizo esta fórmula me arroja el resultado 2 hasta ahí bien pero cuando tengo el numero 0 en la ceda AT1 y se efectúa la fórmula me arroja el resultado como POR porque si tiene que ser 3 no entiendo

el POR es la letra X

Si quieres que tanto una celda vacía como una con 0 la interprete como 10...

Entonces cambia

""       por          0              (en las dos veces que lo puse en la fórmula)

Y listo

Experto también lo hice y tampoco le puedo enviar la hoja a un correo

Con las comillas el 0 así "0" ya lo hice y me sigue dando X

Sin las comillas

""           por     0

64.475 pts. Si de mis mayores gustos, mis disgustos han nacido,...

prueba esta formula =+SI(AT1=0,10,SI(AT1-7<=-1,"X",AT1-7))

Me dice que hay un error en la fórmula y que antes de la fórmula coloque un apotrofe como un punto o asterisco arriba pero nada

Esta raro copie y pegue la fórmula que que puse en este post y funciona, checa la pantalla.

nada experto no me funciona que sera?

Pon una pantalla con el erro que te aparece

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas