Problema con la conexión a internet con XP

He comprado un ordenador y tengo una partición en el disco duro. En una parte tengo la 2ª versión de windows 98 y en la otra XP. Con windows 98 accedo a internet sin problemas pero con Xp me da un problema que lo define así: "error 678 el equipo remoto no responde" y corta la comunicación. Otras veces comunica y otras dice que el número marcado no existe (y siempre es el mismo). He pregintado a varias personas y nadie tiene ni idea. Mi modem es un samtrusb56. ¿Puedes ayudarme?
4

4 Respuestas

0 pts.
El problema parece ser del driver que usa XP o bien, que necesite una cadena AT específica para mantener la conexión.
Bájate el driver de la página del fabricante (si no tienes el disco) e instálalo:
http://www.smlink.com/download/index.htm
Si después de ello sigue sin funcionar correctamente, introduce la siguiente cadena AT, específica para los modems SmartLink, en Panel de Control => Modem => Propiedades => (Pestaña)Avanzadas => Comandos de inicialización adicionales:
AT&F&C1&D2&K3N3%C3 => Aceptar.
En la página de SmartLink (en Support) tienes un documento explicativo de los comandos AT a usar.
Espero que con una de éstas opciones (o ambas) se solucione el problema.
Si no es así, comprueba también que el driver USB esté correctamente instalado y sea la misma versión.
Un saludeT
Te voy a dar más pistas. Al instalarlo dice que no superó la contraseña de windows.
He bajadoel driver que usa xp de la página que me has dicho www. smlink.com y he vuelto a instalar el modem. En esta ocasión me ha ido pidiendo que busque manualmente, ya que el sólito no lo encontraba los siguientes archivos
1- mtlmn5. sy que he encontrado en el CD del modem
2- slnt7554.sy, lo mismo
3- slwdmsup.sy y este ya no lo encuentro por ningún sitio. ¡Esto es un infierno¡
Por otro lado te diré que en el cd del modem dice que trae los drivers win9x/Nt/2000/Me. ¿es posible que mi modem no valga para Xp? Espero que no.
Help me please¡¡
Existe un problema documentado con el driver de XP para manejar los puertos USB. Microsoft a puesto a disposición de los usuarios un parche que soluciona este problema.
Si tienes una copia de XP activada y no has instalado el SP1 (Service Pack 1), bájalo e instálalo. Soluciona muchos errores en el SO (incluido el bug del controlador USB). Si no tienes tu copia activada, bájate el parche de esta dirección: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q307271 (si lees la descripción del problema, comprobarás que es el que tú tienes)
Sin este parche muchos dispositivos USB funcionan mal en XP, no solo el módem, debido a un problema de transferencia de datos (tienes que pinchar sobre el último enlace "Apply Patch After Windows XP Setup").
Para comprobar la versión del controlador USB:
Panel de Control --> Sistema --> Hardware --> Administrator de dispositivos --> Universal Serial Bus Controller --> Selecciona uno de los controladores con doble clic --> Pestaña Driver --> Detalles --> Si la version de usbuhci.sys es 5.1.2600.14 o 5.1.2600.1038, no necesitas aplicar el parche porque tienes actualizado el driver, si es igual a 5.1.2600.0, entonces necesitas aplicar el parche.
Una vez solucionado ésto:
1. Desconecta el modem del puerto USB.
2. Desinstala el driver del modem.
3. Instala el parche o el SP1 de Microsoft si no lo habías hecho ya (es posible que tengas que reiniciar).
5. Conecta el módem y cuando te salga el Asistente de que ha encontrado nuevo Hardware. Cancela.
6. Ejecuta el archivo que bajaste de www.smlink.com para XP. Esto hará que se instale la última versión del driver.
7. Configura la conexión y cruza los dedos ;-)
Lo de que no ha sido firmado por Windows, no te preocupes, significa que el driver no ha pasado por los laboratorios de Microsoft. No supone que no funcione. Es la forma que tiene Microsoft de "lavarse las manos" ante los problemas que tengas con tu SO y así echarle la culpa a terceros (en este caso, el driver del modem) achacando que no ha sido testeado en sus laboratorios.
Siempre que instales un nuevo driver, desinstala el anterior a menos que te especifique que es una actualización (un update).
Cuéntame qué tal. Suerte.
Un saludeT
Hay un refrán que dice algo así: "El que pregunta será tonto durante unos minutos. El que no pregunta, lo será durante toda la vida". ;-)
Efectivamente driver == controlador. He utilizado ambos términos para hacer la diferenciación entre el módem y el USB y no liarte, pero significa lo mismo.
Lo que necesitas:
- Driver del modem para XP.
- Parche para el driver USB de Microsoft.
Los 2 archivos a bajar son ejecutables por lo que su instalación es bastante sencilla (aparentemente).
Tal como dices, bájalos desde w98 y luego cópialos en la partición del XP.
Lo que tienes que desinstalar es el driver del módem, NO el del USB
Para desinstalar:
- Seleccionar el dispositivo (el módem, en este caso) --> menú Acción --> Desinstalar o
- Seleccionar el dispositivo --> (botón derecho del ratón) --> desinstalar.
Ejecuta el parche del USB una vez desinstalado el módem y sin tener nada conectado a ese puerto. De lo contrario, el driver podría estar en uso y no hacer la actualización.
Comprueba en el "Administrador de dispositivos" que el parche se ha aplicado correctamente, comparando la versión tal como te indiqué antes.
Luego conecta el módem y Cancela el Asistente de Instalación de Nuevo Hardware. Ejecuta entonces el archivo que bajaste de SmartLink. Todo se ha de instalar de forma automática y SIN pedirte ningún archivo (tal y como te ocurrió la otra vez).
Para confirmar que todo ha sido correcto, entra, de nuevo, en el Administrador de Dispositivos y comprueba que no aparece ningún triángulo amarillo con una exclamación en su interior, al lado de ningún dispositivo (especialmente en el módem y el USB).
Si todo es OK, configura la conexión a Internet y... SUERTE!
Un saludeT
Muy bien, me estás ayudando mucho. Solo lamento que mis conocimientos de informática sean muy reducidos y tenga que preguntarte mucho.
Efectivamente la versión del controlador es 5.1.2600.0 Preguntas:
¿Cuándo dices desinstalar el driver te refieres al controlador? Si es así no hay problema ya que he visto una opción para desinstalarlo. Si no es así dime como puedo desinstalar los drivers que hay ahora.
Hay instalados 3 controladores, dos de ellos con la misma versión y el tercero con otra que no tiene nada que ver son las numeraciones que me has indicado. ¿Tendría qué desinstalar los tres?.
¿El parche es un ejecutable? Te lo digo por que tengo que bajarlo de intyernet desde windows 98 en una parte del disco duro y posteriormente copiarlo a la otra parte para poder ejecutarlo desde Xp ¿es correcto?
Te estás ganando la máxima puntuación. Muchas gracias. Saludos
Vale lo que pasa que no hay que desinstalar el modem porque no está instalado ya que cuando lo desinstalé en su día después de haber bajado el archivo de los drivers que me dijiste ya no lo he podido volver a instalar, ¿con lo cual me salto ese paso y realizo el resto OK?
Recuerda no tener conectado NADA al puerto USB cuando instales el parche.
Comprueba en el Administrador de dispositivos que, efectivamente, NO tienes instalado el módem. Ni bajo los Dispositivos de Red, ni bajo los de USB.
Ya me contarás.
Un saludeT
No pasa nada por haber ejecutado el archivo ese.
Sigue los pasos tal y como te indiqué antes.
- Desinstalar módem
- Parchear sistema
- Instalar módem
Al desinstalar el módem lo que harás es borrar los drivers (el archivo que ejecutaste).
Un saludeT
Como ya sabes ejecuté el archivo que bajé de smartlink ¿pasa algo por esto? ¿Tengo qué eliminarlo de alguna manera para luego volver a ejecutarlo según me has indicado? Si tengo que borrarlo dime como.
Saludos cordiales
Te cuento: he desinstalado el modem. Lo he desconectado del cable que va al puerto USb. he instalado el parche y al comprobar los controladores de bus serie universal USB ¡Vuelven a salir con la versión antigua¡
He probado a desinstalar los controladores con la versión antigua, de uno en uno y al final todos y vuelvo a aplicar el parche. Cada operación nueva he reiniciado y nada, vuelve a instalar los antiguos. ¿Puede estar el problema en que no he quitado el cable del puerto? En cualquier caso el cable no va a ningún sitio. No se.
Los controladores que aparecen son los siguientes:
3 concentradores raíz USB (version 5.1.2600.0)
3 controladores de host universal USB VÍA Rev 5 o posterior (versión 5.1.2600.0)
1 USB 2.0 Root Hub (version 5.1.2600.0)
1 VIA USB 2.0 Enhanced Host Controller (versión 5.1.2600.41)
Como te he dicho he probado hasta desisntalarlos todos y aplicar después el parche pero vuelven a aparecer los mismos.
Creo que hago bien todo lo que me dices pero no se si me equivoco en algo o que.
Saludos
No desesperes. Ha sido mea culpa.
Resulta que cuando te indiqué el artículo de Microsoft donde recoge el bug (Q307271), no comprobé si el enlace del parche funcionaba correctamente (lleva al Q316397). Ahora lo hice y, ¡Cuál ha sido mi sorpresa!, el parche que te has bajado describe y soluciona un problema diferente (lo fatídico es que al final del artículo, Microsoft lo apunta).
Lo siento, siento no haberlo comprobado antes y haber leído entero el artículo.
Parece ser que Microsoft ha eliminado este parche de su web por estar incluido en el Service Pack 1 (forma parte de su estrategia anti-piratería).
La solución que tienes es bajarte e instalar el SP1.
El problema es que si no tienes tu copia de XP activada, no podrás instalarlo.
Si tienes la licencia activada, instálalo (el SP1). Solucionará este problema y otros tantos con los que aún no te has encontrado. Si no tienes una copia legal, ni lo intentes o el resultado podría ser catastrófico.
Cuéntame y otra vez perdona por el despiste.
Un saludeT
No se que es tener la copia activada. El ordenador me lo trajeron con XP instalado no se si es original o que.
¿que es el SP1?
¿Podemos hacer algo si la copia no es original?
Saludos
Si no tuvieras activado el producto, te saldría un mensaje cada vez que iniciaras XP, durante 30 días (pasados éstos, el sistema dejaría de funcionar si no lo activaras).
Por otro lado, la tienda que te vendió el ordenador debió darte el disco de instalación y un documento con el nº de licencia (y más si pagaste por ello). Si no fue así, deberías llamar a la tienda y preguntar si activaron la copia (aunque dudo que se arriesguen a instalar programas piratas).
También puedes entrar en Sistema --> General y si los datos que aparecen en "Registrado a" son los tuyos, posiblemente sí la registraron/activaron.
El SP1 es un paquete de actualización del sistema operativo. Soluciona diferentes problemas (de controladores, de seguridad, etc) que han ido reportando los usuarios. Es importante instalarlo. Puedes encontrar más información aquí: http://www.microsoft.com/spain/windowsxp/sp1/default.asp
Si la copia que tienes es pirata, existen en internet algunas soluciones de "crakeo", pero conozco a gente que después de haber crackeado el SO e instalado el SP1, el sistema les ha dejado de funcionar y han tenido que reinstalar y prescindir de las actualizaciones. Es algo arriesgado como ves y no te lo aconsejo.
De cualquier forma, bajarte el SP1 desde W98 tiene un problema: el archivo son unos 130 mb (debes seleccionar la "instalación en red" porque la "instalación rápida" (unos 30 mb) requiere XP y conexión a internet).
Prueba, a volver a instalar el módem, a ver si ahora no te da error, y poder actualizar desde XP.
Un saludeT
Hola he visto en sistema - general los datos de instalación y esta mi nombre y el siguiente número 55274-640-0000356-23301, con lo que he pensado que todo estaba correcto. Después de estar toda la noche bajando el sp1 lo he instalado y me ha dado el siguiente error:
"La clave del producto utilizada para instalar windows no es válida. Póngase en contacto con su distribuidor para obtener una clave del producto válida..."
Ya me dirás si hay solución o si sabes como conseguir una y donde instalarla para después volver a intentar la instalación, o que hacer al respecto.
Gracias y saludos
Parece que se está complicando el tema.
Aplicar un parche de crackeo puede suponerte la perdida del sistema. Asegúrate de no tener información importante en esa partición por si tuvieras que reinstalar el XP.
Sigue las instrucciones de esta página:
http://users.servicios.retecal.es/fjvelasco/html/windows/winxpsp1/winzpsp1.htm
Yo NUNCA he crackeado un XP por lo que no te puedo asegurar que funcione. Sé de gente que lo ha parcheado y luego han tenido que reinstalar, y otros, sin embargo, que les ha ido estupendamente (supongo que depende de la versión).
Te darás cuenta con el uso de XP que tiene muchas ventajas con respecto a w98: a nivel de estabilidad, seguridad (si se aplican los parches y se configura correctamente), es más intuitivo, etc., por lo que, a lo mejor, te interesaría comprar una licencia para asegurarte las actualizaciones sin problemas.
Yo, de todas formas, instalaría desde 0, formateando la partición, para así tener un sistema completamente "limpio" antes de instalar el driver del módem.
A ver si ahora tienes suerte ;-)
Un saludeT
No me incordias, pregunta por cuantas dudas tengas.
Afirmar que con dispositivo "compatible" con XP no vas a tener problemas es jugar a la ruleta rusa.
En principio, cualquier dispositivo que tenga drivers para XP no debiera dar problemas, siempre que se tenga también actualizado el sistema pero... la realidad es otra. Y siempre lo ha sido. Tanto con XP, con 98/95, con 2000... Los fabricantes prometen compatibilidad con el SO que luego no es tal (siempre por un problema de acuerdo entre ellos y Microsoft).
Por ejemplo, muchos de los módems que están "regalando" Ya, Terra o Wanadoo en los contratos de ADSL, y que prometen compatibilidad 100% con XP, tienen muchos problemas. El fabricante dice que son modelos descatalagados y el proveedor que es un tema del fabricante. Microsoft a todo ésto, con su nueva política de certificación, se lava las manos. Y son los usuarios quienes sufren los desacuerdos.
El que en el CD de instalación no vengan los drivers para XP, no supone que no sea compatible con XP. Mucho hardware salió al mercado antes de XP y por eso no los traen. Siempre, por sistema, hay que mirar en la página del fabricante para comprobar si existe una actualización de ellos (para cualquier dispositivo y SO aunque los drivers vengan en el CD de instalación).
Un sistema con los drivers actualizados será mucho más estable que otro con la instalación por defecto.
De cualquier forma, y en muchos casos, los drivers para XP sueslen ser los mismo que para 2000.
No desesperes, verás como hayamos solución.
Un saludeT
Solo una pregunta más y ya no te incordio de verdad. Si hubiera unstalado un modem en el que se indicara que es compatible a XP, osea drivers en el CD de instalación ¿hubiera tenido problemas?
Saludos
¡Solucionado¡ Solo faltaba eliminar todos los archivos que tuvieran información del modem para que al cargarlo de nuevo no los leyera. Has sido de gran ayuda. Muchísimas gracias
59.325 pts. Experiencia en hardware de 9 años, de los cuales:...
Esto se debe a que los drivers de tu modem no son los correctos o no paso algún certificado de windows xp, revísalo creo que tienes algo de experiencia, no te doy el procediemnto paso a paso confiando en conoces un poco xp.
También puede ser que la configuración de red en tu equipo no esta dada de alta o no este el protocolo tcp/ip tienes que verificar que esté activo en las propiedades de red, si el modem funciona en win 98 descartamos completamente que sea algo de hardware, probablemente este mal configurado también checa en el administrador de dispositivos si el modem no tiene algún conflicto, este tipo de fallas es muy común cuando los modems están integrados a las tarjetas madre, otro truco es que instales los drivers para windows 2000, a veces funciona O_o! Incluso hasta los de windows me funcionan, checa si en la página del fabricante del modem hay algún drive de actualización,
Aunque lo ideal (y si es el caso) es que remplaces el modem por uno que no este integrado a la tarjeta.
Si no sabes como revisar algo de lo que te menciono avisame, con gusto te ayudo, también si tienes más preguntas o comentarios, si crees que esto soluciona tus dudas
14.975 pts. -Técnico superior en Telecomunicaciones y sistemas...
Tu error es muy común. Puede ser causado por varias motivos.
Te aconsejo que revises los drivers del módem porque xp tiene varios problemas a veces con los modems a la hora de instalarlo. Lo segundo que tienes que mirar es la configuración de la conexión a internet, asegurándote de poner correctamente el teléfono del proveedor, el nombre de usuario y la contraseña; también tienes que comprobar es que has puesto correctamente las dns del proveedor.
Si has revisado todo esto y sigue sin funcionarte, te aconsejo que llames al proveedor porque quizá el problema sea que hay algún error en el servidor ya que al acceder desde dos sistemas operativos, quizá este no se active la cuenta al salir por xp. Y esot sólo ellos te lo pueden solucionar.
Mucha suerte.
79.025 pts. Cirrisculusmm? ezo que e? xDD hmmmm me parece que es pa...
Será smartusb56 ¿no? Prueba con los drivers actualizados para Windows XP: http://www.smlink.com/download/driverlist.htm?
Y mira mucho por la configuración de marcado (prueba a que marque con el códio de área, sin el código, etc...).

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas