Validación datos de columnas

Hola, tengo 3 columnas de datos (Dígito 1, Dígito 2 y Dígito 3) necesito utilizar la herramienta Validación de Datos (Pestaña Datos) para que a un usuario le aparezca un mensaje que diga "un valor por columna, por favor" en el caso de que coloque más de
un valor 1 por columna.

Consigo hacerlo para la columna "Dígito 1" de la siguiente forma:

Criterio de validación PERSONALIZADO (omitir blancos) y la fórmula =SUMA(C18:C27)<=1 y luego ya pongo el mensaje de error del tipo detener.

MI duda es que cuando hago esto me funciona para en dígito 1 pero en las otras dos columnas por debajo del 1 ya escrito no me funciona y el rango seleccionado es el correcto. No se si la fórmula esta mal o si no hago los pasos correctos. Solo quiero que se pueda introducir como máximo un uno por columna (solo son válidos 1 o cero o blanco)

¿Podéis ayudarme? Gracias!

1

1 respuesta

Respuesta
1

Supongo que dígito 1 está en la columna C, dígito2 en la D y dígito3 en la E, entonces pon las siguientes fórmulas en la validación:

En C18

=SUMA($C$18:$C$27)<=1

en D18

=SUMA($D$18:$D$27)<=1

en E18

=SUMA($E$18:$E$27)<=1

Luego selecciona las 3 celdas, las copias y las pegas en las filas de abajo hasta la fila 27, pero con pegado especial: Validación.

Prueba y me comentas

Saludos. Dam
Si es lo que necesitas.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas