Excel

Hola, ante todo gracias por tu atención.
Necesito, desde una hoja de excel, poder coger datos de un access 2000. Es decir quiero poder poner un código cliente en una celda y automáticamente me aparezca nombre cliente, dirección, etc... Que tengo en el access.
Cómo he de hacerlo. GRACIAS.
2

2 respuestas

Respuesta
1
Ante todo, disculpa el retraso en la respuesta.
Yo lo que haría sería importar a Excel la base de datos de Access y después consultaría esta base de datos importada.
Importación
***********
1. "Datos" - "Obtener datos externos" - "Nueva consulta de base de datos".
2. Selecciona, de entre los tipos de archivo que te muestra, "MS Access database*".
3. Pulsa "Aceptar". Ahora te solicita el directorio (ubicación) de la base de datos. Búscala y selecciona la base de datos de access.
4. Te mostrará las tablas que componen la base de datos de access seleccionada. Ahora puedes seleccionar las tablas y campos que deseas importar. Selecciona la tabla (y los campos si no quieres incluir todos) con la flecha que apunta hacia tu derecha.
5. Pulsa el botón "Siguiente".
6. Ahora te solicita si quieres hacer alguna selección (por ejemplo que solamente importe aquellos registro cuyo Campo4 sea "34256". Si quieres traspasar todos pulsa "Siguiente".
7. Ahora te solicita si quieres ordenarlos por algún criterio. Haz lo que creas te conviene y pulsa "Siguiente".
8. Selecciona en la nueva pantalla "Devolver datos a Microsoft Excel" y pulsa "Finalizar".
9. El Excel te preguntará en dónde quieres importarlo. Por omisión se posiciona en la celda "A1". Pulsa "Aceptar".
10. Ya tienes todos los registros de tu base de datos en Access pasados a Excel. Cualquier modificación que sufran estos registros, deberás volver a efectuar este proceso.
11. Solamente te queda ahora insertar una fórmula que, por ejemplo, al insertar el código del cliente te devuelva el resto de información.
Imagina que los datos importados son:
"Código_Cliente" en columna "A".
"Nombre" en columna "B".
"Dirección" en columna "C".
Estos datos asumiremos que se encuentran en la pestaña "BASE DE DATOS".
Imagina, también que el número de registros son 1000, que junto con los nombres de los campos el los datos llegarían hasta la línea 1001.
Por otro lado, quieres insertar en la pestaña "RESULTADOS" los códigos y que te localice el resto de datos. Los códigos asumiremos que se comienzan a insertar desde la celda "A2" hacia abajo. Un ejemplo de códigos es el siguiente:
"A2"=2345
"A3"=4523, ...
Bien, en la celda "B2" insertarías la siguiente fórmula de búsqueda:
"B2"=BUSCARV(+$A2;'BASE DE DATOS'!$A$2:$C$1001;2;FALSO)
Esto buscará el código que has introducido en "A2" en el rango "A2:C1001" de la pestaña "BASE DE DATOS" y te devolverá el dato que aparece en la columna 2 (en nuestro caso es el nombre) del rango.
En la celda "B3" insertarías la siguiente fórmula de búsqueda:
"B3"=BUSCARV(+$A2;'BASE DE DATOS'!$A$2:$C$1001;3;FALSO)
Esto buscará el código que has introducido en "A2" en el rango "A2:C1001" de la pestaña "BASE DE DATOS" y te devolverá el dato que aparece en la columna 3 (en nuestro caso es la dirección) del rango.
Solamente te falta copiar hacia abajo las fórmulas antes descritas.
Espero que esto solucione tu problema.
Si es así, te agradeceré un comentario y que valores y finalices la respuesta.
En caso contrario inserta un comentario explicando tu duda.
Respuesta
1
Para realizar esa tarea consulta en la ayuda buscando bases de datos.
Te adelanto una parte, te vas por el menú "Datos", luego seleccionas "Obtener Datos Externos" (debes tener instalado un complemento que generalmente está instalado) luego seleccionas "Nueva Consulta de base de datos..."
Eso te abre una ventana (Elegir origen de datos)en donde puedes seleccionar el tipo de base de datos que vas a vincular, seleccionas MS Access Database, luego te pide que des la ruta del archivo que deseas consultar... seleccionas el archivo, luego debes adicionar las tablas que vas a utilizar en la consulta (el editor es muy parecido al de consultas de Access) seleccionas los campos y listo. Esa consulta la puedes guardar y puedes seleccionar opciones de actualización al abrir el archivo o como desees, también puedes vincular el valor de una celda a la consulta (eso sería lo que tu pides).
Revísalo con calma, intentalo y verás que es fácil de hacer, el asistente te va dando todos los pasos, si algo no me quedó bien excplicado o no pudiste por favor escríbeme para solucionarlo. De lo contrario te pido el favor de finalizar la pregunta.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas