Como sacar el total de las horas de esta tabla

Tengo estas dos columnas y en este formato, HE hora entrada, HS hora salida, como puedo realizar la fórmula para que me de el resultado de horas entre salida y entrada
HE HS
900 1400
1100 1300
700 930
800 1000
900 1400
1430 1630
1600 1730
700 930
900 1400
1

1 respuesta

Respuesta
1
Si como dices lo tienes en carácter numérico te vale con esta fórmula
Suponiendo 900 en A2 y 1400 en B2
=(B2-A2)/60
Ya me cuentas
El problema es que los datos vienen de copiar una pantalla de linux y copia las horas como números tan cual, sin :, o sea de 9 a 14 h. han transcurrido 5 horas, aplicando la fórmula (B1-a1)/60 el resultado que sale es de 8,33333
Realmente el problema viene cuando hay que sacar las horas cuando son 30, 45, minutos que realmente para restar serían 0,5 0,75
He intentado buscar una fórmula para cambiar el formato a horas de A y B para realmente restar horas y el resultado pasarlo a decimal para poder sumar bien en excel y tampoco
A1 b1 c1 d1 e1 tiempo real transcurrido
900 (9:00) 1400 (14:00) a1/100 b1/100 d1/c1
9,00 14,00 5 5 horas
1100 (11:00) 1300 (13:00) 11,00 13,00 2 2 horas
1130 (11:30) 1300 (13:00) 11,30 13,00 1,7 1,5 horas
Bueno esto de las horas en excel no es tarea fácil
Sigue estos pasos y me cuentas
A1 B1
900 1400
EN C1 pon esta fórmula
=ENTERO(A1/100)&":"&TEXTO(RESIDUO(A1;100);"00")
EN D1 pon esta formula
=ENTERO(B1/100)&":"&TEXTO(RESIDUO(B1;100);"00")
Y EN F1 pones esta otra
=SI(D1-C1<0;D1-C1+1;D1-C1)
Luego pasas las celdas de las fórmulas a formato de horas y comprueba el resultado que seria de horas y minutos
Ya me cuentas
Al formular me da error de #¿NOMBRE? La fórmula contiene texto no reconocido
No te dije que estoy trabajando con el excel 2010, lo siento, y hay nombres de funciones diferentes y las antiguas no las reconoce.
¿Puede ser eso?
Perfecto muchas gracias, el error del nombre era que en el excel 2010 no es RESIDUO si no que es RESTO, han cambiado nuchos nombres.
Repito muchas gracias

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas