Sumando horas totales

Saludos elsa:
Tengo una hoja de excel donde consigne los siguientes datos, A1 fecha B1 HORA DE INGRESO C1 HORA DE EGRESO D1 PUSE LA FORMULITA =SI(B2>C2;12+C2-B2;C2-B2)lo que me da la cantidad de horas trabajadas en turno noche. Mi problema es cuando intento sumar esa columna que contiene 22 registros y me da un numero exorbitante (3096:10:00)o (3:06:¿00)lo cual ninguno de los dos es correcto.me podrías ayudar con esto? Desde ya muchas gracias
1

1 respuesta

Respuesta
1
Colocando como formato [h]:mm:ss a la col DE, la suma debe darte bien.
Revisá el cálculo parcial (resultado de la fórmula), porque depende de cómo ingresaste las horas. En mi ejemplo rellené hacia abajo y me incrementaba en 1 día, 2, 3 y así, luego eso se vé reflejado en el total de hs.
Evidentemente hay algo mal en esta planilla, pero no me doy por vencido, las horas están todas en formato hh:mm:ss, y si sumo eso me da el resto de las horas que pasan de 24, por ejemplo si el resultado debiera ser de 27 horas con diez minutos solo me consigna 3:10:00, si el resultado lo pongo en (h)mm:ss me da 819:22:00, te adjunto los dos ejemplos para mayor comprensión.
En este caso me da como resultado el tiempo exedente más allá de las 24hs
1 20:45:00 03:55:00 07:10:00
2 20:00:00 03:00:00 07:00:00
3 20:00:00 07:12:00 11:12:00
01:22:00
En este caso me da un numero totalmente irreal
1 20:45:00 03:55:00 07:10:00
2 20:00:00 03:00:00 07:00:00
3 20:00:00 07:12:00 11:12:00
817:22:00
Como veras son los mismos números y por una cuestión de comodidad reduje el registro a tres archivos. Me gustaría si pudieras resolver esto que en realidad me esta volviendo loco. Desde ya muchas gracias
Cambiá la fórmula por esta:
=SI(B2>C2;"24:00"+C2-B2;C2-B2)
En mi ej utilicé la col de resultado con formato: [h]:mm:ss y las 2 col de datos con formato hh:mm (aunque pueden tener también el formato del resultado)
Si aún así no obtenés resultados correctos, revisá y comentame tu configuración regional (de fecha/hora) en el Panel de control de Windows.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas