InstallShield Program

No puedo instalar nada con los SETUP de InstallShield Program (Setup Launcher). En Microsoft parece que me dicen que tengo que hacer esto:
Para resolver este comportamiento, establezca los permisos necesarios que se necesitan finalizando la instalación correctamente:
En un símbolo de sistema, escriba:dcomcnfg.exe. The <UITERM> Distributed COM Configuration Properties </UITERM> dialog box is displayed.
Haga clic en la ficha Seguridad predeterminada .
En la sección Permisos de acceso predeterminados, haga clic en Modificar .
Asegúrese de que tiene "Permitir acceso" junto a su nombre.
Si no tiene "Permitir acceso" junto a su nombre, modifique un perfil existente o cree un perfil que tiene los permisos necesarios.
Aplique todos los los cambios e intente ejecutar programa de instalación.
... Esto es una traducción que hace la página; el original dice esto:
To resolve this behavior, set the necessary permissions that are needed to successfully complete the installation:
At a command prompt, type: dcomcnfg.exe. The Distributed COM Configuration Properties dialog box is displayed.
Click the Default Security tab.
In the Default Access Permissions section, click Edit.
Ensure that you have "Allow Access" beside your name.
If you do not have "Allow Access" next to your name, either modify an existing profile or create a new profile that has the necessary permissions.
Apply all the changes and attempt to run Setup.
BUENO. El problema es que no se por donde pillarlo. Lo que se me ocurrió fue ir a Ejecutar y escribir dcomcnfg.exe, pero allí no veo nada que se refiera a "seguridad predeterminada"... ¿QUÉ HAGO?
1

1 respuesta

Respuesta
1
Vamos allá.
El procedimiento que sigues es correcto, entrar a ejecutar, y escribir dcomcnfg.exe.
Ahora llegamos a la diferencia, puesto que los pasos que intentas seguir son para windows anteriores a XP, y sospecho que es el sistema operativo que utilizas.
Ahora pincha sobre "Servicios de componentes", aquí sobre "equipos" y a continuación PERO ESTA VEZ CON EL BOTÓN DERECHO DEL RATÓN sobre "mi pc", seleccionando "propiedades" en el menu emergente. Aquí ya tienes una nueva ventana, con una pestaña llamada "Seguridad COM predeterminada", en la que entras. Aquí, en los permisos de acceso, das al botón de modificar, y marcas "permitir" en la casilla junto a tu nombre de usuario.
No estoy muy seguro que esta sea la solución (a pesar de lo que dicen en microsoft), pero por lo menos ya sabes donde está la maldita "Default security tab" o "Ficha de seguridad predeterminada".
VIVAAA! Nada, sigue sin funcionar. Me pongo manos a la obra para ir guardando archivos y luego formatearé. Muchas gracias por todo :)
Vale. Sí que tengo Windows Xp (se me olvidó ponerlo, je je). Resulta que la casilla ya estaba marcada en "Permitir", así que realmente por ahí no modifico nada.
En una respuesta de otro experto a una pregunta similar en este foro se decía de instalar "mcrepair.exe", de Microsoft, pero lo he hecho y tampoco va. En ese mensaje decía que no le funcionaba el Setup y que le salía un mensaje de error. A mí no me sale ningún mensaje de error, PERO sí he notado que cuando ejecuto el Setup.exe, no pasa nada. Después cuando apago el ordenador, en el momento en que ya no se ven los iconos del escritorio ni nada, entonces SÍ que aparece la pantalla de instalación, pero el ordenador se apaga y no puedo hacer nada.
No tengo ninguna idea más. A ver si sospechas algo. Y muchas gracias por las molestias ;-)
Jejejej. Vamos a ver, porque es un poquitín raro esto que he encontrado.
Se supone que aquí:
http://support.installshield.com/kb/files/Q108312/ikernelupdate.exe
Te bajas la actualizacion oficial del installshield. El problema es que... el tipo de instalacion se realiza precisamente mediante installshield, jajjajaja. Prueba si tienes suerte, sigo pensando.
Jejejej. Vamos a ver, porque es un poquitín raro esto que he encontrado.
Se supone que aquí:
http://support.installshield.com/kb/files/Q108312/ikernelupdate.exe
Te bajas la actualización oficial del installshield. El problema es que... el tipo de instalación se realiza precisamente mediante installshield, jajjajaja. Prueba si tienes suerte, sigo pensando.
Saludos
PD: se me pasa por alto preguntarte si has pasado un antivirus. Hay varios virus que sobreescriben el kernel de installshield y lo inutilizan.
También puedes probar esta opción:
1. Inicie sesión en el equipo como administrador.
2. Haga clic en Inicio y, a continuación, en Ejecutar.
3. En el cuadro Abrir, escriba cmd y haga clic en Aceptar.
4. En el símbolo del sistema, escriba msiexec.exe /unregister y, a continuación, presione ENTRAR.
5. Escriba msiexec /regserver y, a continuación, presione ENTRAR.
6. Reinicie el equipo.
Suerte, sigo investigando.
BUENO. Pues curiosamente sí que se abre y comienza la instalación... PERO!:
"The InstallShield Engine (iKernel.exe)could not be launched.
Acceso denegado ... Aceptar"
Lo del antivirus: también curioso porque tampoco sé que leches pasa que se me ha inactivado y no me deja activarlo AHH! Igual sí que es un virus, aunque en teoría se me actualiza solo casi todos los días...
En fin... no te molestes mucho que acabaré formateando lo más seguro. Esto cada vez va peor y una limpieza de vez en cuando viene bien. Si se te ocurre algo... ¿si no me dices y te finalizo la pregunta ok? Gracias!
Si, tengo una ultima sugerencia.
Entras en Mi PC/c:/Archivos de programa/Archivos comunes/Installshield
y le cambias el nombre a la carpeta "engine". Ahora vuelve a ejecutar ese archivo que has bajado y ya no te denegará el acceso (se me olvidó avisarte que primero tenias que renombrar el antiguo, o borrarlo, aunque de momento mejor solo renombras, por si quieres volver a ponerlo como estaba)
Dicho esto, y después de mucho mirar, creo que si no funciona, deberás hacer como hacemos todo hijo de vecino cuando nos pasan estos expedientes X... formatear y limpieza general.
Viva windows!!! ;-)

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas