Mi pc se reinicia sola

Respuesta de
a
Usuario
Hola, quiero hacerte una consulta ya que me estoy volviendo loco, tengo una pc (compaq presario 7463, 128Mb de ram y disco hitachi de 80Gb), y desde hace un mes se reinicia de la nada, lo hace a veces a cada rato y a veces pasan días y anda bien (la pc esta prendida las 24 horas ya que tengo una fm), el único mensaje que da después de reiniciar es "windows se ha recuperado de un error grave" (tengo windows xp), durante más de un año funciono bien y esto empezó de la nada, probé formatear el dico e instalar nuevamente windows pero la falla sigue y me esta enloqueciendo, una cosa más en el visor de sucesos aparece el siguiente mensaje: "AMLI: la BIOS ACPI está intentando leer desde una dirección de puerto E/S no válida (0x71), que se encuentra en el intervalo de dirección protegido 0x70 - 0x71. Esto puede llevar a una inestabilidad del sistema. Póngase en contacto con el proveedor del equipo para obtener asistencia técnica", y por ultimo si esta sonando música desde la pc se empieza a entrecortar unos segundos antes de reiniciarse, te voy a agradecer mucho si me puedes ayudar ya que me tiene loco este problema, desde ya muchas gracias.
Pd.: perdón por lo largo de esta consulta pero quería darte la mayor cantidad de datos posible.
Experto
Tu problema se encuentra con el disco duro, y la configuración DMA según el caso.

Si tienes XP, actualízalo por medio del Windows Update, al ServicePack2, junto con las demás actualizaciones disponibles. Si el disco no tiene problemas físicos, entonces, esto solucionará tu problema.

Si no, abre la propiedades de Mi PC, entrás en la pestaña AVANZADO, y luego a Inicio y Recuperación (parte inferior), y quitas el check en Reiniciar Automáticamente. Lo cual hace que ante un error de Windows, el PC no se reinicie.

Para asegurarte, realiza una comprobación de disco duro:

Botón Inicio, Ejecutar.

Digitar chkdsk /f /r y dar clic en Aceptar.

Con esto verificas que el disco esté en buen estado físico, o por el contrario que debes cambiarlo.
Usuario
Muchas gracias por tu ayuda te comento que se soluciono el problema instalando el service pack 2, muchas gracias.