Fórmula para contar valores únicos y omitiendo celdas vacías

Necesito de una ayuda por parte de ustedes.

Tengo esta fórmula: =SUMA(1/CONTAR.SI(C11:D12;C11:D12)) (matriarcal) la cual funciona y cumple con lo que estoy buscando

Pero necesito ampliar el rango y que la fórmula funcione si la celda esta en blanco

Para que se entienda

C        D

10     11

11     10

La fórmula arrojaría como resultado 2 que son los valores únicos

C      D

10    11

13    11

La fórmula arrojaría como resultado 3 que son los valores únicos

Mi problema está es que necesito que la fórmula que arriba menciono, se pueda aplicar hasta una cierta fila y si las celdas están en blanco funcione como explique antes, ya que si estiro la fórmula hasta la fila deseada me devuelve como resultado error, pero si selecciono solo el rango de valores funciona a la perfección

1 respuesta

Respuesta
1

Puedes utilizar la función SUMAPRODUCTO, aunque es matricial, no es necesario entrarla con Shift + Control + Enter:

=SUMAPRODUCTO((C11:D20<>"")/CONTAR.SI(C11:D20;C11:D20&""))


O puedes seguir utilizando la función SUMA, pero deberás entrarla con las teclas

Shift + Control + Enter:

=SUMA((C11:D20<>"")/CONTAR.SI(C11:D20;C11:D20&""))

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas