Fórmula Condicional Si Anidada Simplificación

Tenfo un casilla de validación de datos en la que me muestra los meses, en función del mes elegido me muestra el acumulado, la fórmula que uso es una condiciona anidada como se ve

=+SI($P$1="Enero";Tabla213[@Enero];SI($P$1="Febrero";+Tabla213[@Enero]+Tabla213[@Febrero];SI($P$1="Marzo";+Tabla213[@Enero]+Tabla213[@Febrero]+Tabla213[@Marzo];SI($P$1="Abril";+Tabla213[@Enero]+Tabla213[@Febrero]+Tabla213[@Marzo]+Tabla213[@Abril];SI($P$1="Mayo";Tabla213[@Enero]+Tabla213[@Febrero]+Tabla213[@Marzo]+Tabla213[@Abril]+Tabla213[@Mayo];SI($P$1="Junio";Tabla213[@Enero]+Tabla213[@Febrero]+Tabla213[@Marzo]+Tabla213[@Abril]+Tabla213[@Mayo]+Tabla213[@Junio];SI($P$1="Julio";Tabla213[@Enero]+Tabla213[@Febrero]+Tabla213[@Marzo]+Tabla213[@Abril]+Tabla213[@Mayo]+Tabla213[@Junio]+Tabla213[@Julio];SI($P$1="Agosto";Tabla213[@Enero]+Tabla213[@Febrero]+Tabla213[@Marzo]+Tabla213[@Abril]+Tabla213[@Mayo]+Tabla213[@Junio]+Tabla213[@Julio]+Tabla213[@Agosto];SI($P$1="Septiembre";Tabla213[@Enero]+Tabla213[@Febrero]+Tabla213[@Marzo]+Tabla213[@Abril]+Tabla213[@Mayo]+Tabla213[@Junio]+Tabla213[@Julio]+Tabla213[@Agosto]+Tabla213[@Septiembre];SI($P$1="Octubre";Tabla213[@Enero]+Tabla213[@Febrero]+Tabla213[@Marzo]+Tabla213[@Abril]+Tabla213[@Mayo]+Tabla213[@Junio]+Tabla213[@Julio]+Tabla213[@Agosto]+Tabla213[@Septiembre]+Tabla213[@Octubre];SI($P$1="Noviembre";Tabla213[@Enero]+Tabla213[@Febrero]+Tabla213[@Marzo]+Tabla213[@Abril]+Tabla213[@Mayo]+Tabla213[@Junio]+Tabla213[@Julio]+Tabla213[@Agosto]+Tabla213[@Septiembre]+Tabla213[@Octubre]+Tabla213[@Noviembre];SI($P$1="Diciembre";Tabla213[@Enero]+Tabla213[@Febrero]+Tabla213[@Marzo]+Tabla213[@Abril]+Tabla213[@Mayo]+Tabla213[@Junio]+Tabla213[@Julio]+Tabla213[@Agosto]+Tabla213[@Septiembre]+Tabla213[@Octubre]+Tabla213[@Noviembre]+Tabla213[@Diciembre];0))))))))))))

Existe alguna forma de simplificar la fórmula son muchas las tablas de las que obtengo los datos y me da muchos errores

2 Respuestas

Respuesta
1

Prueba esta fórmula y comentas

=SUMA(INDIRECTO("Tabla213[[Enero]:["&$P$1&"]]"))

Tal vez por tu versión de excel la debas utilizar con @, prueba así:

=SUMA(INDIRECTO("Tabla213[[@Enero]:[@"&$P$1&"]]"))
Respuesta

Muestra una imagen para ver como tienes los datos, sobre todo de la 'Tabla213'

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas