Problema en Pegado de Hoja

Buenos Días Expertos,

Tengo un problema... En principio parece hasta chorra, pero no tengo forma de hacerlo funcionar.

He realizado una macro, donde copio los datos de un libro. Es decir, selecciono la hoja1 completa la copio al portapapeles y después la pego en hoja2, todo esto lo hace automático, pues bien... Cuando lo pega me cambia el formato y me deja las celdas con una marquita verde, me lo convierte todo a numero, no me respeta el formato de la hoja inicial, en cambio si lo hago paso a paso sin utilizar la macro el pegado lo hace correcto.

1

1 Respuesta

3.689.425 pts. Si me amas, siempre voy a estar en tu corazón; si me...

¿Y cuáles son los pasos que hace manualmente que sí te funcionan?

¿Y cuál es la macro que tienes?

Buenos Días,

Los pasos con los que si me funciona son los normales, si selecciono manualmentre y pego con Edicion/Pegar ( no hay problemas ) pero si ejecuto el botón con este código me cambia el formato.

Sub COPIAYPEGA()
'
' COPIAYPEGA Macro
'

'
    Sheets("hoja1").Select
    ActiveSheet.PasteSpecial Format:="Texto Unicode", Link:=False, _
        DisplayAsIcon:=False, NoHTMLFormatting:=True
    Sheets("MENU").Select
End Sub

Tu macro está pegando con un pegado especial.

Intenta con esta macro

Sub Macro17()
'
    Sheets("Hoja1").Cells.Copy
    Sheets("Hoja2").Select
    Range("A1").Select
    ActiveSheet.Paste
End Sub

Saludos.Dante Amor

Recuerda valorar la respuesta.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas