Ayuda con la implementación de fórmula condicional en excel

Increíble tu experiencia en excel,
lo he visto por la cantidad de preguntas que has respondido en el tablón.
Entonces aquí va una tercer pregunta rara mía.
Existirá alguna forma para que en una celda se escriba una fórmula pero dentro de esa fórmula si se cumple la condición
Entonces se ejecute un macro.
Ejemplo de lo que quiero
( =SI(A1=7,EJECUTA MACRO,0)
Perdón por todas mis 3 preguntas porque no he tomado tiempo para aprender visual basic para las macros en excel.
Bueno, gracias y feliz año 02
1

1 Respuesta

201.000 pts.
Las funciones devuelven valores, por ello, una función no puede ejecutar una macro, pero para lo que quieres están los eventos, entra al editor de visual basic, da un doble click en la hoja que te interese, selecciona el evento Change y escribe lo siguiente
Private Sub WorkSheet_Change(ByVal Target As Range)
If Target.Address = "$A$1" Then
If Target.Value = 7 Then
MsgBox "Esta es mi macro"
End If
End If
End Sub
Ahora, en esta hoja, cada vez que la celda A1 tenga el valor 7, te mostrara un mensaje...
Muy buen consejo,
ahora sí ya me dediqué a estudiar un tutorial llamado "programar macros en excel" por tanto en un futuro te pediré ayuda sobre problemas mucho más difíciles.
Muchas gracias

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas