Eliminar ciertos valores en izquierda y derecha

Tengo un gran problema con una base de datos de SAP que tengo que convertir, lo ejemplifico así.
1. 000291327A200
2. 000020447A000
3. 0000000000000000000000000002858008402100
4. 0000000000000000000000000002858008402100
5. 00000A2C0006231700
6. 00000A2C0010250000
El uno y dos (de 13 valores) se le debe de quitar un valor a la izquierda y dos a la derecha para que quede de 10 valores "00291327A2" por ejemplo.
El 3 y 4 (de 40 valores) hay que quitarle 27 valores a la izquierda hasta que de 13 valores "2858008402100" por ejemplo.
El 5 y 6 (de 18 valores) hay que quitarle 5 valores a la izquierda para que quede de 13 valores "A2C0006231700"
Son 4,000 celdas en la columna A y quisiera que por favor me apoyaran con la fórmula o el código de la macro para lograrlo, ya que lo necesito para mi trabajo y ya lo he intentado de mil maneras y no me es posible obtener el resultado que busco.
1

1 Respuesta

98.125 pts.
Te paso unas fórmulas y te explico
Suponiendo tus datos en la columna A introduce esta fórmula en C1
=SI(D1=13;EXTRAE(A1;2;10);SI(D1=18;EXTRAE(A1;6;13);SI(D1=40;EXTRAE(A1;28;13);"")))
Y esta otra en D1
=LARGO(SUSTITUIR(A1;" ";""))/(LARGO(A1)-LARGO(SUSTITUIR(A1;" ";""))+1)
Esta ultima te cuenta los caracteres de la celda A1 y te da la cantidad total de caracteres que según especificas seria 13 ó 18 ó 40
Y la 1º que te puse es la que te daría el resultado según el valor encontrado en D1
Luego solo tienes que correr las fórmulas hacia abajo y ya lo tienes
Ya me cuentas si te vale así
Hola D2enri.
Es la primera consulta que realizo y te agradezco el haber respondido en tan poco tiempo, no me lo esperaba.
Ya ingresé las fórmulas, lamentablemente la de la columna "D" me arroja -11,-38 o -16 según el caso y la de la "C" no me aparece nada aunque ingrese el 13, 18 o 40 de forma manual y no sé por que.
Espero puedas apoyarme.
Saludos.
Pues lo cierto es que comprobé las fórmulas de nuevo y no me dan esos datos
1º ¿Qué excel tienes 2003 ó 2007?
2º conforme pones aquí los datos supongo que el formato de celdas lo tendrás como texto pues si no es así te saldría algo así 2,85801E+12 pero aun así nunca te debería dar negativo
Si me pasas tu correo te mando un ejemplo ó bien pásame tu archivo y veré donde puede estar el fallo
[email protected]
Gracias D2enri, resolví mi problema de forma temporal haciéndolo con demasiados pasos, pero me gustaría poder enviarte el archivo para quedarme con el conocimiento de como hacerlo de una manera más eficiente.
Te reitero el agradecimiento por el tiempo invertido.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas