Comparar dos oraciones y que una contenga al menos

Hola Expertos:
Me urge resolver lo siguiente y sé que ustedes tienen la respuesta!:
Tengo un archivo excel con 2 hojas:
- En 1 tengo los nombres de empleados con el siguiente formato: 1er nombre, 2° nombre, 1er apellido y 2° apellido
- En la otra tengo los nombres de los mismos empleados con el siguiente formato: 1er nombre y 1er apellido más una columna con el dato de la indemnización.
- Lo que necesito es que se comparen los nombres de la 2a hoja con los de la 1a (que obviamente no tienen el mismo formato, y como se supondrá hay muchos nombres repetidos, por lo que la tarea se hace difícil a pie, por ser muchos los empleados a comparar).
- Luego que los compare (que será comparando 1er nombre y 1er apellido) debe poner el en la 1a hoja el dato de la indemnización al empleado que le corresponde.
¿Cómo puedo hacerlo?... Si necesitan el archivo os lo puedo enviar!
Gracias anticipadas!
1

1 respuesta

Respuesta
1
Creo que lo más seguro es que separes texto en col, en ambas hojas
Así en hoja1 tendrás 4 col y en hoja 2, solamente 2 + la indemnización
Luego oculta las 2 col que no usas para no confundirte, en hoja 1
y ahora una fórmula como la siguiente, donde tendrás que ajustar las referencias a las tuyas:
=+SUMAPRODUCTO((Hoja2!$A$1:$A$200=A1)*(Hoja2!$B$1:$B$200=B1)*(Hoja2!$C$1:$C$200))
El primer rango de hoja2 será la col del primer nbre y la 2da del apellido, la 3ra tendrá los datos de indemnización.
Esta fórmula solo te servirá si por cada combinación nbre-apellido hay 1 solo importe, de lo contrario te lo sumará.
Sdos. Si te queda alguna duda, podes pedir aclaraciones
La consulta ya lleva 1 semana abierta y respondida. Podes pedir aclaraciones si te queda alguna duda, de lo contrario por favor FINALIZA así otros usuarios también pueden recibir respuesta .
Sdos
Elsa

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas