Mouse

El mouse dejó de funcionar luego de instalar algunos controladores. Estoy casi seguro que el modem provocó el conflicto.
Al iniciar windows aparece el mensaje de que no se ha detectado mouse conectado al computador y en DOS el controlador del mouse lo instala en el com1, sin embargo en la opción de testeo del controlador el mouse no responde. Por otro lado el modem se instala en el com1 y si lo cambio de puerto el mouse ya no puede ser instalado en el com1 ni en ningún otro puerto.
Además no existía puerto de impresora, pero al modificar algunas opciones del BIOS relativas a puertos windows detectó el puerto de impresora y ahora funciona normalmente. Gracias a estas modificaciones el mouse respondió en la opción de testeo pero al entrar a windows apareció el mensaje mencionado antes y no ha vuelto a funcionar más. (Ni en windows ni en DOS)
4

4 respuestas

Respuesta
1
Yo te recomendaría que desinstales todos los dispositivos y después instales uno por uno separadamente, o sea cada vez que instales uno, reinicia que te o configure, otra que podes hacer es entrar al panel de control, y en sistema entrar y fijarte cuales son los dispositivos que están haciendo conflicto, y quítalos, te das cuenta de esto porque tienen un signo amarillo de admiración al lado del dispositivo que esta haciendo conflicto.
Respuesta
1
Si no usas Windows 3.1 o 3.11, el controlador para DOS no debe estar instalado, ya que hay que usar el de Windows 95, 98, etc.. Por tanto te recomiendo que no cargues el controlador para DOS. Por otro lado si el programa de testeo no responde es que hay un error de hardware grave. Comprueba lo siguiente; que en la BIOS el puerto COM al que esta conectado el ratón este activado, que ambos puertos utilicen interrupciones y/o direcciones de memoria diferentes (si es posible utiliza la configuración aotumatica) y sobre todo comprueba que todo esto aparece reflejado en el cuadro de configuración del hardware. Ten en cuenta que la configuración de la BIOS es autoexplicativa, y si no entiendes una opción busca en el manual cual es su funcion; me parece que el problema que estas teniendo es que no entiendes bien que significa cada campo en la configuración de la BIOS, y puede que haya cosas desactivadas y/o activadas, que no deberían estarlo, y por otro lado puede que haya interrupciones y/o direcciones de memoria compartidas, cuando los puertos serie, dado que son una reliquia de los primeros tiempos del computador personal, no pueden compartir interrupciones.
Muchas gracias.
Tengo una duda: cuándo hablas de "ambos puertos", ¿te refieres al del mouse y el del modem?, ¿Debería tener a cada uno en un puerto distinto y entonces intentar la modificación del bios?
Lo pregunto por lo que mencioné antes: que el mouse puede ser instalado en DOS en el com1 usando el controlador, pero que esto funciona sólo si el modem está instalado en el com1.
No mencioné que ocupo windows 95
Gracias
Los puertos de comunicaciones dependen de la UART, cada uno se distingue por una dirección de memoria distinta donde leer y escribir, que corresponde a su vez con lo sregistros de la UART, etc... En un PC hay dos puertos, habitualmenete el ratón esta en el primero, pero el nombre es puro formulismo, porque cambiando la dirección de memoria de cada uno se puede cambiar el orden. El controlador de DOS suele ser bastante restrictivo a este respecto, no te fíes de el. Obviamente lo que hay que tener es el modem en un puerto y el ratón en otro, cada uno con interrupciones y direcciones de memoria diferentes, y si el sistema es PnP no habrá mucho problema para detectarlos todo. Pero claro, si empiezas a hacerle un lio y le cargas un controladro de DOS para el ratón en un puerto en el que no esta el ratón, aunque el controlador cree que si que esta, porque confunde el modem con el ratón, pues el jaleo que se monta es monumental, ya que el sistema tiene informaciones contradictorias, y siempre podrán más las que vayan forzadas por flujos activos, como es un controlador que esta cargado en memoria modificando el comportamiento normal del sistema, ya que un controlador no es más que un interprete que lee de unas direcciones, escribe en otras y tiene un cierto comportamiento, y que por tanto hace creer a windows que es el ratón, actuando de capa intermedia entre el y el hardware, pero claro, como el hardware no es el ratón, pues al final no funcionara ni el modem ni el ratón. Comprueba que no se están asignando incorrectamente los recursos de hardware y de software, ya que cuando varios flujos trabajan sobre lo mismo el resultado puede ser desastroso.
Gracias nuevamente y perdón por la insistencia.
¿"PnP" es "Plug&Play"? Mi modem es plug& play y el com1 es el predeterminado, pero noté que en el administrador de dispositivos del panel de control no aparece el com1, sino que el com2, com3 y el de impresora. ¿Debería aparecer el com1? ¿Serviría de algo agregar un nuevo puerto desde el ícono "agregar nuevo hardware"?
¿Si no apareciera el com1 serviría cambiar el puerto predeterminado del modem? (2 o 3 en este caso) el manual del modem indica cómo. Aparece que es necesario modificar jumpers.
Gracias y perdón por la molestia
El nombre del puerto (COM1, COM2, etc...) depende de la combinación de interrupción y dirección de memoria que tenga, eso lo tienes que modificar en la placa, de modo que para COM1 existe una combinacio; en este momento tus dos puertos estarán usando los recursos de COM2 y COM3. Por otro lado deduzco que tu modem es interno, eso quiere decir que tendrá su propia UART o la emulara por software, por tanto añade un puerto más, que tiene que ser distinto a los que tienes en la placa base, ya que de lo contrario habría un conflicto. Por tanto asegurate de que la configuración de los dos puertos de placa base no es igual al del modem, seguramente compartirán un recurso, pero no ambos. Desde luego una vez el modem tenga su COM, este debe aparecer, pero cuidado porque los modems de UART virtual no tienen el puerto como tal, y hay que instalar un controlador especial para que lo encuentre. Si no es tu caso, y supongo que el modem, si lleva jumpers, no sera totalmente PnP, tendrás que añadirlo a mano, porque si no aparece es muestra de que el modem no esta funcionando.
Respuesta
1
Prueba a desactivar en la bios el com2 para que el modem vaya a ese puerto y deje el com1 libre para el mouse.
Respuesta
1
Bueno a mi me paso una vez eso y creo que el problema solo lo solucione reinstalando el sistema operativo, aunque podrías desinstalar los controladores del mouse y que checaras si queda ok si no regresa la config del bios como estaba antes, ¿una pregunta de que eran los controladores?
Gracias, lo intentaré.
Hace poco comprobé que al instalar los controladores del módem se produjo el conflicto
(Cuando desinstalé el modem y lo sace de la placa madre el mouse funcionaba, volví a ponerlo y apareció el error nuevamente)

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas