Autonumeración con Excel

Hola, espero que puedas ayudarme!
Estoy necesitando una función para autonumerar, y luego cuando oredene los datos, cada registro quede con el numero que se le asigno al generar el dato.
Peor todavía, porque para otro caso, necesito que ese numerador dependa del campo anterior, que es rubro.
Entonces tengo para el Rubro "A", Artículo 1 - 2- 3, etc. Para ele Rubro "B", Artículo 1-2-3 etc.
Bueno, estoy esperando tu respuesta que apuesto que me darás una solución!
Muchas gracias!

1 respuesta

1
Respuesta de
Hola, buen día.
Imagina que tienes una hoja de calculo de tres columnas ubicadas de la siguiente forma:
Columna A: Rubro (A; B; C; etc)
Columna B: Nombre del articulo.
Columna C: Código.
Luego en la celda C2, escribirás la siguiente función:
=SI(CONTAR.SI($A$2:A2;A2)=0;"";CONTAR.SI($A$2:A2;A2))
Esto te numerara los items a medida que lo cargues.
Este código se mantendrá siempre y cuando tu regla de ordenación sea rubro, código o código - rubro.
Sí la regla de ordenear es por el nombre debes crear una macro que te fije las fórmulas en texto antes de hacerlo. Puedes integrar las dos cosas: Fijar y ordenar.
Cualquier duda avisame.
TC
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje