Totalizar valores distintos de una columna

Tengo por ejemplo una lista ... que se yo, podría ser algo así:
word
excel
sql
excel
word
sql
sql
Quiero una fórmula que me diga cuantos valores distintos existen en esa columna... en este ejemplo seria 3... cual seria la fórmula que me arroje 3 como resultado en este ejemplo
Desde ya muchas gracias
JIMMY

2 respuestas

1
Respuesta de
Hola amigo, lo que te recomendaría es usar la función =Contar.Si(). Por ejemplo, en la celda C1 puedes poner "A Buscar", en la C2 haces una validación de datos (Datos-Validación, y escoges de A1 hasta A9, si es que ahí están tus datos). En D2 puedes poner: =Contar.Si(A1:A9,C2).
Con esto ya puedes saber cuántos hay de cada dato que buscas.
jcgonzalez3165@gmail.com
Añade un comentario a esta respuesta
1
Respuesta de
Si en el rango no hay celdas vacías, puedes usar:
=SUMAPRODUCTO(1/CONTAR.SI(A1:A7,A1:A7))
Y si hay celdas vacías:
=SUMAPRODUCTO((A1:A7<>"")/CONTAR.SI(A1:A7,A1:A7&""))
Saludos.
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje