Encontrar un solo carácter dentro de una celda

Apreciado amigo: recurro a ti, a fin que me colabores por favor con la siguiente fórmula:
En la columna A tengo varias celdas con datos como:
Celda A1 = B - N
Celda A2 = B
Celda A3 = B / N
Celda A4 = C*N
Celda A5 = A + 2
Celda A6 = N
Celda A7 = M_n
Y así sucesivamente, en cientos de celdas...
En lo que necesito que por favor me colabores, es en encontrar por ejemplo una fórmula para la celda F1, de manera que si en la Celda A1 encuentra la letra N sin importar si está sola, si es en minúscula o mayúscula, si está acompañada o no de un espacio, carácter, símbolo o letra cualquiera, me coloque el número 1; de lo contrario me deje la celda en blanco., Lo importante es que esté presente la letra ene sin importar nada más
En resumidas cuentas: una fórmula que busque dentro de la celda la letra ene sin tener en cuenta sus posibles letras, espacios, tildes, números o caracteres de compañía; si la encuentra, que el resultado me arroje el número uno; y al no encontrarla, me deje la celda en blanco,.
Espero poder contar pronto con tu acertada respuesta.
Gracias por tu tiempo y paciencia.. Cordial saludo, Wilson

2 respuestas

1
Respuesta de
Hola Wilson!
Trabajemos en tu caso de inmediato. Comprendo a la perfección tu solicitud.
1.- Trabajaremos con los mismos datos que esta en tu post. Entonces estaremos de acuerdo que tenemos 7 datos.
2.- Ahora como tu lo deseas. En la celda F1 ingresa la siguiente fórmula ( O cópiala y pégala para evita errores en la digitación)
=SI(ESERROR(SI(HALLAR("N";A1)>=1;1;""));"";SI(HALLAR("N";A1)>=1;1;""))
[Fijate en tu separador de argumentos que puede ser punto y coma o coma. Yo he empleado punto y coma ";"]
Tal como lo pediste, si en la celda encuentra la letra N o n independientemente como se visualice le devolverá uno "1", caso contrario nada ""
***
Esta fórmula que esta en F1 arrastrala hacia abajo para que afecte a tus demás celdas que tienes en la columna A.
Espero haberte ayudado en tu caso. Me comentas como te fue.
No olvides de finalizar y puntuar al final de esta página, el cual es importante.
Saludos!
Christian
Añade un comentario a esta respuesta
1
Respuesta de
Hola amigo, aquí podría estar tu posible solución:
=Si(SumaProducto((Largo(A1)-Largo(Sustituir(A1,"N",""))))+
SumaProducto((Largo(A1)-Largo(Sustituir(A1,"n","")))),1,"")
jcgonzalez3165@gmail.com
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje