ana_madrid5

ana_madrid5

 España @ana_madrid5 desde - visto
Preguntar

Actividad pública reciente

Ha valorado "Buena" la respuesta

Excel vba problema al ejecutar macro desde checkbox

respondió: Bueno ya que solo pones eso no se el evento que estas poniendo para aplicar la macro. Solo necesitas quitar los paréntesis a Now, te dejo un ejemplo: Private Sub CheckBox1_Click() If CheckBox1.Value = True Then Range("C2").Value = Now End Sub Se...
Ha valorado "Excelente" la respuesta

Excel VBA. Función Index/Match en macro

respondió: Tu fórmula es equivalente a BuscarV: =BUSCARV(A2;Tablas!$O$6:$Q$8;3;1) Si quieres el código para poner todas las fórmulas en la columna B hasta donde la columna A tenga datos: Sub Formula1() With Range("B2:B" & Range("A" & Rows.Count).End(3).Row)...
Ha preguntado en el tema en y en 2 temas más

VB Outlook Macro mover correo entrante a otra carpeta Visual Basic

Estoy empezando a programar macros en VB para Outlook. La idea es que al recibir correos con ciertas características (remitente o un asunto concreto) salte un mensaje de alerta en pantalla. Quería sustituirlo porque se muevan esos correos a otra...
Sin respuestas
Ha valorado "Excelente" la respuesta

Excel VBA macro crear MsgBox con datos de una columna

respondió: Si la col A no tiene otras celdas más que las de la tabla (sin totales u otros textos al final) y las celdas no tienen fórmula (es decir que donde se ven vacías realmente lo están) el fin de rango se puede obtener como: x = Range("A" &...
Ha valorado "Excelente" la respuesta

Macro Excel Visual Basic. Importar varios ficheros XML a la vez

respondió: Prueba lo siguiente: Sub importar_Xml() Dim sPath As String, sFile As String Dim Book As Workbook, sh As Worksheet Dim lr As Long ' With Application .ScreenUpdating = False .Calculation = xlCalculationManual .EnableEvents = False .DisplayAlerts =...
Ha valorado "Excelente" la respuesta

Macro excel VBA modificar código para copiar y pegar en otra hoja

respondió: Con lo siguiente podrías copiar y pegar Sub prb() Sheets("ORIGEN"). Range("B8", Sheets("ORIGEN").Range("B" & Rows. Count).End(3)). Resize(, 5). Copy Sheets("Destino").Range("A" & Rows. Count).End(3)(2) End Sub Pero si no hay registros a copiar,...
Ha valorado "Excelente" la respuesta

Excel Macro VBA importar xml a excel

respondió: Agrega esta opción a esta línea: Set Book = Workbooks.OpenXML(FilePath, LoadOption:=2) 'Asi también se puede escribir: 'Set Book = Workbooks.OpenXML(FilePath, LoadOption:=xlXmlLoadImportToList) En la ayuda de Excel aparece esto: Specifies how Excel...
Ha empezado a seguir a
Ha valorado "Excelente" la respuesta

Excel visual basic macro error en condición en IF

respondió: Prueba lo siguiente para validar "*Almacén*", en minúsculas o en mayúsculas, con acento o sin acento: If Range("A" & i).Value = "Referencia 23" And _ (Not LCase(Range("D" & i).Value) Like LCase("*almacén*") Or _ Not LCase(Range("D" & i).Value) Like...