Tengo una duda sobre Fechas y Horas

Esta tabla adjunta es de un calendario donde al seleccionar la fecha y la hora anda todo ok, pero al momento de hacer la consulta, despliega tanto la fecha y la hora juntos, que también esta bien, el tema es que si quiero filtrar solo por una solo fecha en cuestión, no me muestra nada,,, es decir... Cuando ingreso en la consulta el criterio de búsqueda "Entre [Favor Ingresar Inicio Fecha a Imprimir Ej: 10/07/06] Y [Confirme El Final Fecha a Imprimir Ej: 12/07/06]", calculo que debe ser porque las horas están en dichos registros, ¿la pregunta concreta es como hago para filtrar solo la fecha en el formulario pero que obvio imprima las fechas y horas juntas... Me explique bien?

saludos...

1 respuesta

Respuesta
2

Si no te quieres complicar mucho, añade un campo nuevo a tu consulta que muestre solo la fecha, le desmarcas la casilla de mostrar, y le pones a ese campo "oculto" el criterio de filtrado en vez de ponerlos al campo ApptStart, algo así:

Un saludo.


¡Gracias! 

No me sale capo, me da este error en el punto y como parece, y si lo quito, lo mismo

El punto y coma (;) es el separador que tengo en mi Access por mi configuración regional. En tu caso es probable que el separador sea la coma (,). Simplemente cambia uno por otro y te debiera funcionar.

Capo, acá te envío el paso a paso..

Así mismo capo, cambie el punto y como por la coma y surgió el paso a paso que te muestro en el mensaje anterior...

Te da ese error porque pones un nombre de campo (AppStart) que no existe en tu tabla. Si lo cambias, solucionado

¡Gracias! 

Disculpame pero no entiendo, como que no existe el campo en la tabla? si existe, ahi guarda las fechas.... mira en el adjunto pls...

A ver, en la imagen que pones (punto 1), en el nuevo campo has puesto:

Expr1:CFecha(Format([AppStart],"dd/mm/aaaa"))

Como no tienes ningún campo que se llama así (AppStart) te lo pide como parámetro (punto 2) y a la larga te da el error que muestras al final.

Si corriges el nombre, porque lo has escrito mal y no es AppStart, sino ApptStart (te falta la t entre App y Start...) ya lo tienes...

¡Gracias! 

Tenes razón capo, se me perdió la t.... Funciona de maravilla y me di cuenta también que si ponía que busque el rango de fechas 01/03/19 no lo reconocía y tiene que se 01/03/2019...

Muchísimas Gracias por la Ayuda!!

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas