Formular en excel desde VBA

Tengo una base que supera los 60,000 Filas y unos 10 a la derecha.

Resulta que tengo que calcular unos datos pero quiero hacerlo con Vba y dejar solo el resultado /No quiero que quede la formula solo el resultado en valores.

1. Quiero que la columna Valor operado ("G")me realice una especie de sumar. Si con datos de otra hoja Llamada ("Detalle").

2. Como realizo una resta simple entre la columna ("G") - La columna ("E"). Con base en eso yo podría sacar las otras columnas que son división, Porcentajes.

Agradezco a la persona que me pueda ayudar con esto!, Claro si es que se puede hacer lo que quiero!

Feliz día.

2

2 respuestas

Respuesta
1

En el caso de esta resta es simple:

[H2] = [G2]-[E2]

Y en otras más complejas utilizarás otro tipo de instrucciones. Por ejemplo si necesitas el resultado de:

=SUMAR.SI(Detalles!A1:A6;D7;Detalles!C1:C6)

La instrucción será (ajusta rangos y nombre de hoja)

sumando = Application.WorksheetFunction.SumIf(Sheets("Detalles").Range("A1:A6"), Range("D7"), Sheets("Detalles").Range("C1:C6"))
'colocar el resultado en alguna celda
[I2] = sumando

PD) Desde la página 1 de la sección Funciones de mi sitio podés descargar la lista completa de funciones en español-inglés.

En manual 500Macros encontrarás un capítulo completo de cómo trabajar desde VBA con Funciones.

¡Gracias! 

Me funciono aunque tuve que cambiarle algunas cositas pero me ayudaste con la duda que tenia, solo tuve que dejarla así.

Private Sub Valor_Operado()
'Vamos a Escribir el valor que opero
    Range("A1").Select
    Range(Selection, Selection.End(xlDown)).Select
    Rango = Application.WorksheetFunction.CountA(Selection)
    Dim Contador As Long
    For Contador = 2 To Rango Step 1
    sumando = Application.WorksheetFunction.SumIf(Sheets("Detalle de pagos").Range("A:A"), Range("A" & Contador), Sheets("Detalle De Pagos").Range("M:M"))
'colocar el resultado en alguna celda
    Range("G" & Contador) = sumando
    Next
End Sub

Igual muchas gracias

Respuesta

Esto puede servir fíjate

https://youtu.be/d4VgP82naPI

https://youtu.be/yYsO9lDewsY

https://youtu.be/_0N4SmBWi-k

[url=https://programarexcel.com]
https://programarexcel.com[/url] 

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas