Fórmula

Arrastro la fórmula previamente para que al introducir los datos calcule automáticamente el resultado. ¿Cómo puedo hacer para que las celdas que contienen la fórmula aparezcan en blanco
mientras no se rellenen las celdas con los datos introducidos para realizar el cálculo?
1

1 Respuesta

540.825 pts. Por falta de tiempo para responder como me gusta...
Desde luego que mucho dependerá de cuál sea tu fórmula concreta, pero el concepto básico para resolver tu planteo es que debes utilizar un condicional (SI) que evalúe si las celdas que se usan en el cálculo están vacías o no.
Por ejemplo, puedes tener un caso típico para evitar la división por cero en una fórmula de este tipo:
=SI(G7=0,0,A23/G7)
[Considera si sueles usar comas o punto y coma para separar argumentos de las funciones. Yo usé ","]
Como ves, si la celda G7 no tuviera un valor, el resultado de esta fórmula es cero y evitas el error #DIV/0!
Si, eventualemente, no quisieras que se vea ese cero, puedes utilizar la opción de no mostrar ceros (En "Herramientas" | "Opciones" | "Ver" quita la marca a la casilla: "Valores cero")
Otro caso, por ejemplo, es la resta, donde puedes usar el operador "O" para evaluar si falta ingresar alguno de los miembros de la resta. Tal fórmula sería:
=SI(O(ESBLANCO(B5),ESBLANCO(C5)),0,C5-B5)
Nota que aquí evalúo que un dato no haya sido ingresado en las celdas y no si alguno de ellos es cero, puesto que esto podría ser una operación posible.
De todos modos, mafigo, queda en ti adaptar esta idea a tu propia fórmula.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas