Error en función anidada

Por favor vuelvo sobre un ejemplo para que me digan a donde esta el error en la siguiente fórmula para el ejemplo abajo mencionado GRACIAS!
=SI(E5<=2;$D$17*D5;SI(E5>2<5;$D$18*D5;SI(E5>=5;$D$19*D5)))
Calcular la bonificación por antigüedad que le corresponde a cada empleado (utilizando la función SI y referencias a celdas fijas)
                                  D E F
4 DEPARTAMENTO SUELDO antigüedad
5 ventas 456,12 3
6 producción 355,89 4
7 contable 758,91 2
8 contable 487,05 6
9 contable 690,52 5
10contable 298,31 8
         C D
Antigüedad INCREMENTO
17   <=2                    0%
18 >2<5                  5,00%
19 >5 10,00%
1

1 Respuesta

165.800 pts. Más de 35 años en la informática y más de 20 trabajando...
La fórmula está mal escrita.
Una cosa, si quieres que los rangos de años de antigüedad puedan variar podrías ponerlos en formato "Desde"-"Hasta". En ese caso tendrías:
      C D E
    Desde Hasta Incremento
17 0 2 0%
18 3 5 5%
19 6 999 10%
Con este formato, tu fórmula para la línea 5 sería:
=E5*(1+si(y(F5>=$C$17;F5<=$D$17);E17;0)+si(y(F5>=$C$18;F5<=$D$18);E18;0)+si(y(F5>=$C$19;F5<=$D$19);E19;0))
Volviendo al formato que tienes tu. En tu caso, la fórmula que tienes que poner para la misma línea 5 es:
=E5*(1+si(F5<=2;$D$17;si(F5<=5;$D$18;$D$19)))
NOTA: entiendo que en la columna DE está el departamento, en la columna E el sueldo y en la columna F la antigüedad.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas