Página asp

Saludos experto, tengo una duda y haber si puedes saberlo y ayudarme.
tengo una pagina web html, el cual utilizo un frame para
dividirlo ,y en una parte sale una pagina asp el cual
en versiones algo antiguas falla(como si no existiera).La pagina asp
tiene un contador, set pageCount = Server.CreateObject("MSWC.PageCounter") %>
This page has been accessed <%= pageCount.pageHit %> times.
¿Creo qué es por lo que falla.a que debe ser esto y como puedo
arreglarlo?
Gracias y saludos.
1

1 respuesta

Respuesta
1
Lo que quieres hacer depende de que lenguaje de Script estés usando.
Si usas VBScript (lo más normal si son páginas ASP's), el objeto que estás utilizando no es el correcto. Prueba con este:
Set pcobj = Server.CreateObject("IISSample.PageCounter") ;
Si no funciona, no dejes de decírmelo, y buscaremos otra solución.
Lo que me dijiste, no funciona, lo que pasa es que con mi contador, con versiones antiguas
Pues no funciona, porque el de mi amigo que tiene un w98, el contador pues se reinicia
O no cuenta. En cambio con el 2000
Si que va perfectamente con vbscript
Saludos.
Vamos a ver... ¿tu amigo y tu VISITÁIS esa página o la SERVÍS?
Quiero decir...¿el servidor de esa página es siempre el mismo y los dos la visitáis? O los dis (¿Tu y tu amigo) hacéis de servidores?
No, creo que me he explicado mal .
MI amigo tiene un navegador Internet explorer algo antiguo, y me ha dicho que falla el contador, y lo comprobé y es verdad ..., con mi contador utilizando
con el servidor(IIS) de mi casa me funciona, pero yo no lo sirvo desde mi casa, busque un alojamiento de páginas
asp y introducí mi página, pero parece
que no funciona con el servidor alquildado
Creo que ahora lo entiendo.
Verás... los componentes de Servidor (ASP) no dependen en absoluto del navegador que se utiliza para ver la página. Las únicas incompatibilidades que pueden darse en este sentido son a nivel de cliente (JavasCript, Cookies, etc).
Creo que el problema está en la configuración del navegador de tu amigo... quizás en las cookies. ¿Las acepta su máquina?
He buscado por toda la red y no hay casos como el tuyo, por lo que me reafirmo en la hipótesis de la configuración de tu amigo. Deberíais probar con la misma version del explorador de tu amigo, en otro ordenador.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas